Php/xml probleme affichage menu flash [Résolu]

Signaler
Messages postés
66
Date d'inscription
jeudi 16 mars 2006
Statut
Membre
Dernière intervention
16 juillet 2007
-
coockiesch
Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
-
Salut,

j'ai un probleme avec un document xml générer par du php.
Voila, je génère un document xml qui est pointé par un menu en flash. Le probleme est que mon menu est généré dynamiquement et je crois que le naviguateur a du mal à suivre.
Je m'explique :
quand je modifie mon menu, on voit qu'il est bien modifier en l'ouvrant avec un editeur mais dans le naviguateur il n'est pas à jour. C'est le menu avant modification qui est présent.

Donc je suis obliger de mettre un lien vers le fichier xml, puis quand je visualise le fichier xml, de faire un actualiser et là si je reviens sur l'affichage du menu , il est à jour.

J'avais utilisé ceci :
<META HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE, MUST-REVALIDATE">
<META HTTP-EQUIV="PRAGMA" CONTENT="NO-CACHE">                  
<META HTTP-EQUIV="EXPIRES" CONTENT="0"> 

dans mes pages ce qui me permettaient de vider le cache. Je croyais que cela marchait mais en approfondissant mes test j'ai vu que non.

SVP, help me.(je suis sur que c'esst un truc tout con en plus)                         

3 réponses

Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
3
Alors acceptes ma réponse, stp, comme ça le sujet passe en résolu! :)

@++

R@f

www.allpotes.ch: Photos, humour, vidéos, gags, ...
"On dit que seulement 10 personnes au monde comprenaient Einstein. Personne ne me comprends. Suis-je un génie???"
Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
3
Salut!
Et en faisant ça avec PHP?
<?php
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
header("Last-Modified: ".gmdate("D, d M Y H:i:s")." GMT");
header("Cache-Control: no-cache, must-revalidate");
header("Pragma: no-cache");
?>

@++

R@f

www.allpotes.ch: Photos, humour, vidéos, gags, ...
"On dit que seulement 10 personnes au monde comprenaient Einstein. Personne ne me comprends. Suis-je un génie???"
Messages postés
66
Date d'inscription
jeudi 16 mars 2006
Statut
Membre
Dernière intervention
16 juillet 2007

merci mais ca a l'air de refonctionner.

je sais pas ce qui trip mais bon on verra ca plus tard. Mais en plus ca aurait pas été pour mon cas car faut que le cache se vide a chaque nouvelle connexion. C'est sur l'intranet d'une usine et ils y accèdent par des widgets.

Mais ça à l'air d'être bon donc je vais passer à la suite. Merci

++