Problème moteur de recherche

Signaler
Messages postés
105
Date d'inscription
mercredi 10 novembre 2004
Statut
Membre
Dernière intervention
16 octobre 2005
-
Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
-
Bonjour, j'ai crée un moeur de recherche très simple avec base de donnée. Voici la structure de ma base :
CREATE TABLE sonarty_search (
id INT UNSIGNED AUTO_INCREMENT NOT NULL PRIMARY KEY,
nom VARCHAR(200) NOT NULL,
des VARCHAR(250) NOT NULL,
loc VARCHAR(180) NOT NULL,
cle VARCHAR(200) NOT NULL
)

Et pour rechercher à l'interieur de ma table, j'utilise cette requète :
$requete = mysql_query("SELECT id,nom,des,loc FROM $Table1 WHERE 'cle' LIKE '%$q%'");

Seulement voila, mon problème c'est que par exemple j'inscri un site avec PHP my admin, je met :
id (id) : 1
nom (nom) : Google
description (des) : Moteur de recherche rapide et puissant
location (loc) : http://www.google.com
mots clées (cle) : Google google

et quand je recherche 'Google' sa me met que cette recherche n'existe pas alors que les mots clées du site google que j'ai inscrits sont 'Google et google'. Je ne comprend pas pourquoi sa ne marche pas, de plus je suis débutant en php. J'ai pensé à faire des recherches avec fulltext mais sa ne marchait pas non plus, ou je n'y arrivais pas . Quelqun pourrait m'aider à résoudre cette érreur qui j'éspère à l'aire pas trop dure. Merci beaucoup !

>>>> Tony 4758 <<<<

1 réponse

Messages postés
2268
Date d'inscription
mercredi 27 novembre 2002
Statut
Membre
Dernière intervention
13 septembre 2013
3
Salut!

Si tu affiches ta variable $q, ca te donne quoi?



@++



R@f

www.allpotes.ch: Photos, humour, vidéos, gags, ...

"On dit que seulement 10 personnes au monde comprenaient Einstein. Personne ne me comprends. Suis-je un génie???"