Problème link de "UnrealIRCd" avec "Anope" (service irc)

Signaler
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005
-
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005
-
Bonjour à tous,

J'ai instalé pour la première fois unrealircd sur mon pc qui à pour système d'exploitation Windows.

J'ai tout bien configurer dans le fichier unrealircd.conf donc mon serveur fonctionne mais par contre j'ai essayer d'installer les service IRC "Anope" et la j'ai un problème au niveau du link de "unrealircd" vers "Anope".

Quand je tape /rehash sur IRC il me met comme erreur:

(11:53:00) -irc.interplanet.be- *** Notice -- Rehashing all files via the console
-
(11:53:00) -irc.interplanet.be- *** Notice -- Loading IRCd configuration ..
-
(11:53:02) -irc.interplanet.be- *** Notice -- Configuration loaded without any problems ..
-
(11:53:02) -irc.interplanet.be- error binding to local port for services.interplanet.be[80.201.90.207]:Can't assign requested address

Dans mon fichier "unrealircd.conf" j'ai mis pour le linké:


link services.interplanet.be {
username services;
hostname 80.201.90.207;
bind-ip 80.201.90.207;
port *;
hub *;
password-connect "services";
password-receive "services";
class servers;


options {
autoconnect;
};
};

Et dans mon fichier services.conf j'ai mis:


RemoteServer 127.0.0.1 7000 "services"
#LocalAddress nowhere. 0
ServerName "services.interplanet.be"
ServerDesc "Services MFS Serveur"
ServiceUser "[mailto:services@interplanet.be services@interplanet.be]"
NickServName "NickServ" "Nickname Server"
ChanServName "ChanServ" "Channel Server"
MemoServName "MemoServ" "Memo Server"
BotServName "BotServ" "Bot Server"
HelpServName "HelpServ" "Help Server"
OperServName "OperServ" "Operator Server"
GlobalName "Global" "Global Noticer"
#DevNullName "DevNull" "/dev/null -- message sink"
HostServName "HostServ" "vHost Server"
PIDFile services.pid
MOTDFile services.motd
NickServDB nick.db
#PreNickServDB prenick.db
ChanServDB chan.db
BotServDB bot.db
OperServDB oper.db
NewsDB news.db
ExceptionDB exception.db
HostServDB hosts.db
# AutokillDB akill.db
HelpChannel "#aide"
#LogChannel "#services"
#LogBot
NetworkName "interplanet"
#Numeric 0

... et la suite de la configuration des services qui est encore bien longue ...

Si vous aviez une idée d'ou vient le problème ce serais cool lol :p

Merci d'avance à tous

A++

Fabien S.

13 réponses

Messages postés
969
Date d'inscription
lundi 16 juin 2003
Statut
Membre
Dernière intervention
1 juillet 2012
1
link services.interplanet.be {

username "services";


hostname "127.0.0.1";

bind-ip "*";

port "7000";

password-connect "services";

password-receive "services2";

hub "*";

class "servers";

};



Ne mets pas le même pass pour la "connect" et le "receive" :)
Messages postés
969
Date d'inscription
lundi 16 juin 2003
Statut
Membre
Dernière intervention
1 juillet 2012
1
trompé entre le pass "connect" et "receive" :§
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

lol encore pire

(13:07:43) -irc.interplanet.be- *** Notice -- Rehashing all files via the console
-
(13:07:43) -irc.interplanet.be- *** Notice -- Loading IRCd configuration ..
-
(13:07:44) -irc.interplanet.be- *** Notice -- Configuration loaded without any problems ..
-
(13:07:46) -irc.interplanet.be- *** Notice -- Connection to services.interplanet.be[127.0.0.1] activated.
-
(13:07:47) -irc.interplanet.be- *** LocOps -- Link denied for irc.interplanet.be([mailto:unknown@127.0.0.1 unknown@127.0.0.1]) (No link block named 'irc.interplanet.be') [@127.0.0.1.1824]
-
(13:07:47) -irc.interplanet.be- *** LocOps -- ERROR :from services.interplanet.be[127.0.0.1] -- Link denied (No matching link configuration) [@127.0.0.1.1824]
-
(13:07:47) -irc.interplanet.be- *** LocOps -- ERROR :from services.interplanet.be[127.0.0.1] -- Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
-
(13:07:47) -irc.interplanet.be- *** LocOps -- Server services.interplanet.be[127.0.0.1] closed the connection

et dans unrealircd.conf j'ai mis:


link services.interplanet.be {
username "services";
hostname "127.0.0.1";
bind-ip "*";
port "7000";
hub "*";
password-connect "services";
password-receive "services2";
class servers;


options {
autoconnect;
};
};

comment sa ce fait ?


Fabien S.
fabien@interplanet.be
Messages postés
969
Date d'inscription
lundi 16 juin 2003
Statut
Membre
Dernière intervention
1 juillet 2012
1
link services.interplanet.be {

username "services";

hostname "127.0.0.1";

bind-ip "*";

port "7000";

hub "*";

password-connect "services2";

password-receive "services";

class "servers";

options {

autoconnect;

};

};
Messages postés
879
Date d'inscription
vendredi 22 octobre 2004
Statut
Membre
Dernière intervention
29 juin 2007

Pour le pass c'est pas grave, tu peux mettre le même.

Mets ça :
link services.interplante.be {
username *;
hostname *;
bind-ip 127.0.0.1;
port 7000;
password-connect "services";
password-receive "services";
hub *;
class servers;
options {
autoconnect;
};
};


-=[MaX_62]=-
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

Hello MaX_62,

j'ai donc mis sa:


link services.interplanet.be {
username services;
hostname 127.0.0.1;
bind-ip 127.0.0.1;
port 7000;
hub *;
password-connect "services";
password-receive "services";
class servers;
options {
autoconnect;
};
};

et il me met cmme erreur tjrs:

(14:47:54) -irc.interplanet.be- *** Notice -- Rehashing all files via the console
-
(14:47:55) -irc.interplanet.be- *** Notice -- Loading IRCd configuration ..
-
(14:47:56) -irc.interplanet.be- *** Notice -- Configuration loaded without any problems ..
-
(14:47:58) -irc.interplanet.be- *** Notice -- Connection to services.interplanet.be[127.0.0.1] activated.
-
(14:47:59) -irc.interplanet.be- *** LocOps -- Link denied for irc.interplanet.be([mailto:unknown@127.0.0.1 unknown@127.0.0.1]) (No link block named 'irc.interplanet.be') [@127.0.0.1.3086]
-
(14:47:59) -irc.interplanet.be- *** LocOps -- ERROR :from services.interplanet.be[127.0.0.1] -- Link denied (No matching link configuration) [@127.0.0.1.3086]
-
(14:47:59) -irc.interplanet.be- *** LocOps -- ERROR :from services.interplanet.be[127.0.0.1] -- Closing Link: [127.0.0.1] (Link denied (No matching link configuration))
-
(14:47:59) -irc.interplanet.be- *** LocOps -- Server services.interplanet.be[127.0.0.1] closed the connection

J'ai l'impression qu'il cé ce connecter mais que ya un problème dans les services, non ?

Au faite dois-je remplacer les * que ta mise dans le code par quelque chose ?


Fabien S.
fabien@interplanet.be
Messages postés
879
Date d'inscription
vendredi 22 octobre 2004
Statut
Membre
Dernière intervention
29 juin 2007

Non, les * sont corrects.
Essaie de mettre les services sur le 6667 au lieu du 7000 pour voir, vérifies bien que tous les paramètres de ta conf sont corrects (ex : NetworkName, ServerName, RemoteServer)



-=[MaX_62]=-
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

hum avec le port 6667 ya aussi une erreur:

(15:03:37) -irc.interplanet.be- *** Notice -- Rehashing all files via the console
-
(15:03:37) -irc.interplanet.be- *** Notice -- Loading IRCd configuration ..
-
(15:03:37) -irc.interplanet.be- *** Notice -- Configuration loaded without any problems ..
-
(15:03:37) -irc.interplanet.be- *** Notice -- Connection to services.interplanet.be[127.0.0.1] activated.
-
(15:03:38) -irc.interplanet.be- *** LocOps -- ERROR :from services.interplanet.be[127.0.0.1] -- Closing Link: [127.0.0.1] (This port is for clients only)
-
(15:03:38) -irc.interplanet.be- *** LocOps -- Server services.interplanet.be[127.0.0.1] closed the connection

hum donc sa vien bien du fichier services.conf on dirais

---> vérifies bien que tous les paramètres de ta conf sont corrects (ex : NetworkName, ServerName, RemoteServer)

hum dans kel fichier sa se trouve sa ?

Fabien S.
fabien@interplanet.be
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

hhaaa mé dans services.conf:

ServerName "services.interplanet.be"
ServerDesc "Services MFS Serveur"
ServiceUser "[mailto:services@interplanet.be services@interplanet.be]"

je doit pas mettre le meme nom que le nom de mon serveur qui se trouve dans unrealircd.conf ?!


Fabien S.
fabien@interplanet.be
Messages postés
2466
Date d'inscription
vendredi 23 juillet 2004
Statut
Membre
Dernière intervention
1 août 2010
1
Il me semble que si mais le meilleur moyen c'est d'essayer :)
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

Je doit partir, quelque heure, je reviens ce soir probablement vers 18h30-19h00.

Vos suggestions sont toujours la bienvenue mdr

A++

merci


Fabien S.
fabien@interplanet.be
Messages postés
879
Date d'inscription
vendredi 22 octobre 2004
Statut
Membre
Dernière intervention
29 juin 2007

A "ServerName" tu mets le serveur que t'as mis dans le LINK de UNREALIRCD.CONF
Et dans "RemoteServer" tu mets : RemoteServer 127.0.0.1 6667 "services"
Ensuite, pour NetworkName, tu mets le meme que tu as mis dans unrelaircd.conf au Set::Network-Name block
Autre chose : le nom du serveur des services doit être le meme que celui que tu as noté dans unrealircd.conf au Set::Services-server block



-=[MaX_62]=-
Messages postés
74
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
3 septembre 2005

Merci MaX_62, je verrai sa directement dès que je rentre chez moi,

Je te tien au courrant

A++

Fabien S.
fabien@interplanet.be