JpGraph et problème GD Support.... [Résolu]

Messages postés
58
Date d'inscription
mercredi 13 octobre 2004
Dernière intervention
13 novembre 2005
- 22 mars 2005 à 10:16 - Dernière réponse :
Messages postés
23
Date d'inscription
jeudi 9 novembre 2000
Dernière intervention
22 mars 2005
- 22 mars 2005 à 10:56
Bonjour je m'essaie au PHP
Je dois afficher des radars statistiques... Et j'ai trouvé JpGraph : ce qui m'a l'air super pour ce que ej veux faire!
Mais le hic (car ya un hi sinon je ne posterai pas ici!) c'est que je n'arriva pas à faire tourner un exemple de la doc fourni, il me dit :

JpGraph Error This PHP installation is not configured with the GD library. Please recompile PHP with GD support to run JpGraph. (Neither function imagetypes() nor imagecreatefromstring() does exist)

Je vous mets le code au cas ou :
<?php
include ("../jpgraph.php");
include ("../jpgraph_radar.php");

// Some data to plot
$data = array(55,80,26,31,95);

// Create the graph and the plot
$graph = new RadarGraph(250,200,"auto");


// Add a drop shadow to the graph
$graph->SetShadow();


// Create the titles for the axis
$titles = $gDateLocale->GetShortMonth();
$graph->SetTitles($titles);
$graph->SetColor('lightyellow');


// ADjust the position to make more room
// for the legend
$graph->SetCenter(0.4,0.5);


// Add grid lines
$graph->grid->Show();
$graph->grid->SetColor('darkred');
$graph->grid->SetLineStyle('dotted');


$plot = new RadarPlot($data);
$plot->SetFillColor('lightblue');
$plot->SetLegend("QA results");


// Add the plot and display the graph
$graph->Add($plot);
$graph->Stroke();
?>
Voilà je ne sais vraiment pas quoi faire, compiler PHP n'est pas ce que ej voudrais faire, car si ça parait facile sous Linux, je bosse en ce moment sur une plateforme Windows EasyPHP...
Ma version de PHP est la 4.3.10, donc je devrai avoir normalement la GD support....

Je n'ai pas trouvé de références à ma question, j'espère qu'elle n'a pas été posée auparavant (quoique...)
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
23
Date d'inscription
jeudi 9 novembre 2000
Dernière intervention
22 mars 2005
- 22 mars 2005 à 10:24
1
Merci
salut, il faut que tu ailles dans \Program Files\EasyPHP1-7\apache que tu ouvre le fichier php.ini et que tu enlèves le ; devant extension=php_gd2.dll il ne sera plus en commentaire et tu pourras utiliser jpGraph

voila normalement c'est bon

Merci lenuldeservice 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de lenuldeservice
Meilleure réponse
Messages postés
58
Date d'inscription
mercredi 13 octobre 2004
Dernière intervention
13 novembre 2005
- 22 mars 2005 à 10:36
1
Merci
D'abord Merci pour la réponse rapide!

J'ai fait ce que tu m'as dit, mais ça ne marche pas!

J'ai deux PC tests (un sous EasyPHP1.7 et l'autre sous 1.8 mais c'est pareils sous les deux...)

Merci zeldoi5 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de zeldoi5
Meilleure réponse
Messages postés
58
Date d'inscription
mercredi 13 octobre 2004
Dernière intervention
13 novembre 2005
- 22 mars 2005 à 10:42
1
Merci
Oui !!! Je viens de redémarrer Apache : je venais de me dire : il faut que je le redémarre!
Et ça marche!!!!

Merci très très très beaucoup!!!!!!

Merci zeldoi5 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de zeldoi5
Meilleure réponse
Messages postés
23
Date d'inscription
jeudi 9 novembre 2000
Dernière intervention
22 mars 2005
- 22 mars 2005 à 10:56
1
Merci
de rien c'est normal à plus et bonne continuation

Merci lenuldeservice 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de lenuldeservice
Messages postés
58
Date d'inscription
mercredi 13 octobre 2004
Dernière intervention
13 novembre 2005
- 22 mars 2005 à 10:38
0
Merci
Il me met ça exactement comme message :

Notice: Use of undefined constant IMG_PNG - assumed 'IMG_PNG' in c:\program files\easyphp1-7\www\jpgraph.php on line 367
JpGraph Error This PHP installation is not configured with the GD library. Please recompile PHP with GD support to run JpGraph. (Neither function imagetypes() nor imagecreatefromstring() does exist)
Commenter la réponse de zeldoi5
Messages postés
23
Date d'inscription
jeudi 9 novembre 2000
Dernière intervention
22 mars 2005
- 22 mars 2005 à 10:39
0
Merci
ca te met la meme erreur?il faut faire cette manipulation quand

easyphp n'est pas lancé essai de le relancé.
Commenter la réponse de lenuldeservice

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.