Probleme de requete pour affichage membre

[Résolu]
Signaler
Messages postés
116
Date d'inscription
vendredi 6 août 2004
Statut
Membre
Dernière intervention
22 septembre 2005
-
Messages postés
1250
Date d'inscription
mardi 15 juillet 2003
Statut
Membre
Dernière intervention
30 septembre 2007
-
Bonjour @ tous, voila mon probleme je fait une requete par le biais d'un formulaire qui envoit l'id du membre, mais a l'affichage cela ne me montre que les image mais pas les données du membre voila mon php pour la requete:


<?php
$id = $_POST["id"];


// Paramètres de connexion à la base de données
include "includes/functions.inc.php";


@mysql_pconnect($BD_serveur, $BD_utilisateur, $BD_motDePasse)
or die("Impossible de se connecter au serveur de bases de données.");
@mysql_select_db($BD_base)
or die("Impossible de se connecter à la base de données.");


$requete = "SELECT id='$id' FROM table_utilisateurs ";


$result = mysql_query($requete);

if ($enreg = mysql_fetch_array($result)) {
// Si une ligne a été trouvée c'est que le couple
// (identifant, mot de passe) est valide

print "<table width=\"320\" height=\"200\" border=\"0\" cellpadding=\"0\" cellspacing=\"0\" bordercolor=\"#3300CC\">
----, &nbsp;</td>

----

,
".$enreg["id"].",

----

".$enreg["departement"].",

----

Né(e) le " . $enreg["jour"] . "/" . $enreg["mois"] . "/" . $enreg["annee"] . ",

----

&nbsp;,
Fait le ".$enreg["ins"].",

----

&nbsp;,
".$enreg["grade"]."
</td>
</tr>
</table>


";
} else {
echo "Une erreur inattendue est intervenue.
";
}
?>

j'espere que quelqu'un va pouvoir m'aider merci

3 réponses

Messages postés
1250
Date d'inscription
mardi 15 juillet 2003
Statut
Membre
Dernière intervention
30 septembre 2007
1
salut,

tu est sur que ta requete fonctionne là

essai plutot ça

$requete = "SELECT * FROM table_utilisateurs WHERE
id='".$id."' LIMIT 1
";

ça devrait etre mieux

Je te donne une idée, tu me donnes une idée, nous avons chacun deux idées.
Mon site Internet
Messages postés
116
Date d'inscription
vendredi 6 août 2004
Statut
Membre
Dernière intervention
22 septembre 2005

oki merci g trouver mon probleme voila la solution merci pour ton aide :
<?php
$id = $_POST["id"];


// Paramètres de connexion à la base de données
include "includes/functions.inc.php";


@mysql_pconnect($BD_serveur, $BD_utilisateur, $BD_motDePasse)
or die("Impossible de se connecter au serveur de bases de données.");
@mysql_select_db($BD_base)
or die("Impossible de se connecter à la base de données.");


$requete = "SELECT * FROM table_utilisateurs Where id='$id'";


$result = mysql_query($requete);

if ($enreg = mysql_fetch_array($result)) {
// Si une ligne a été trouvée c'est que le couple
// (identifant, mot de passe) est valide

print "<table width=\"320\" height=\"200\" border=\"0\" cellpadding=\"0\" cellspacing=\"0\" bordercolor=\"#3300CC\">
----, &nbsp;</td>

----

,
".$enreg["id"].",

----

".$enreg["departement"].",

----

Né(e) le " . $enreg["jour"] . "/" . $enreg["mois"] . "/" . $enreg["annee"] . ",

----

&nbsp;,
Fait le ".$enreg["ins"].",

----

&nbsp;,
".$enreg["grade"]."
</td>
</tr>
</table>


";
} else {
echo "Une erreur inattendue est intervenue.
";
}
?>
encore merci
Messages postés
1250
Date d'inscription
mardi 15 juillet 2003
Statut
Membre
Dernière intervention
30 septembre 2007
1
pas de quoi
@+

Je te donne une idée, tu me donnes une idée, nous avons chacun deux idées.
Mon site Internet