Probleme avec cfhttp

cs_iDoc Messages postés 2 Date d'inscription mercredi 17 mars 2004 Statut Membre Dernière intervention 12 octobre 2004 - 12 oct. 2004 à 18:42
syndrael Messages postés 2378 Date d'inscription lundi 4 février 2002 Statut Membre Dernière intervention 29 décembre 2012 - 18 oct. 2004 à 14:47
dans un cfloop, j'ai inséré un cfhttp pour envoyer un formulaire à une methode asp.

cela se passe bien pour la premiere boucle mais ensuite il plante...en debuggant je me rend compte que les variables envoyées sont dupliquées à chaque loop...

exemple :
loop 1 : <cfhttpparam name = "name1" type="formfield" value ="test">
la methode asp reçoit name1= "test" (tout est ok)

loop 2 : <cfhttpparam name = "name1" type="formfield" value ="toto">
la methode asp : name1= "testtoto" (?????)

existe-il un moyen d'initialiser ces variables envoyées !!!!

par avance merci,

2 réponses

cs_Metrox Messages postés 267 Date d'inscription jeudi 19 septembre 2002 Statut Membre Dernière intervention 8 septembre 2013
17 oct. 2004 à 18:36
Euuh, j'ai jamais utilisé de cfhttp, mais tu as essayé ceci:
<cfif NOT IsDefined("name1")>
<cfhttpparam name="name1" type="formfield" value="toto">?

M@x ---> Go on www.metrox.be
0
syndrael Messages postés 2378 Date d'inscription lundi 4 février 2002 Statut Membre Dernière intervention 29 décembre 2012 19
18 oct. 2004 à 14:47
Euh.. Alors la dernière fois ou j'ai utilsé un CFHttp, on allumait nos cigarettes avec des silex !! LOL !!
Y'aurait po moyen de faire un <cfdump var="#cfhttp#"> ?? Si c'est possible alors là ça devient intéressant car tu peux triturer cette structure.. Un peu kom le CFFtp.. Et donc tu fais ce ke veux.. Y compris vider ton Name1 avant de le re-remplir..
S.
0