Problème de FileLoadException en chargeant un assembly [Résolu]

Signaler
Messages postés
264
Date d'inscription
dimanche 14 avril 2013
Statut
Membre
Dernière intervention
23 mai 2014
-
Messages postés
264
Date d'inscription
dimanche 14 avril 2013
Statut
Membre
Dernière intervention
23 mai 2014
-
Salut à tous,
Je développe sous Visual C# 2010 express, et mon projet consiste entre autre à créer un exécutable pour charger un fichier dll, via Assembly.LoadFrom. J'ai moi même créé ledit fichier dll.
Le problème est le suivant :
Sous Visual C#, quand je lance le système en debuggage, tout marche
Si je génère un fichier exe, et le lance depuis l'explorer, il plante en tentant de charger le fichier dll
J'ai le même comportement en mode debug ou release.

J'ai regardé les versions d'assembly du fichier dll, c'est 1.0.0.0, comme pour l'exe.
J'ai essayé d'écrire 1.0.0.*, ca change rien

Pouvez vous m'aider à trouver le problème?

Merci beaucoup

@+. Hermios

4 réponses

Messages postés
264
Date d'inscription
dimanche 14 avril 2013
Statut
Membre
Dernière intervention
23 mai 2014
2
Bon ben en fait, si je charge directement l'assembly comme ressource dans mon programme, je n'ai plus ce problème, donc... problème plus ou moins résolu.
Merci de ton aide en tout cas :)


@+. Hermios
Messages postés
14790
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
15 mai 2021
155
Bonjour,

Quel est le texte complet de l'erreur ?

---------------------------------------------------------------------
[list=ordered][*]Pour poser correctement une question et optimiser vos chances d'obtenir des réponses, pensez à lire le règlement CS et aussi ce lien[*]Quand vous postez un code, merci d'utiliser la coloration syntaxique (3ième icône en partant de la droite : )
[*]Si votre problème est résolu (et uniquement si c'est le cas), pensez à mettre "Réponse acceptée" sur le ou les messages qui vous ont aidés./list
---
Messages postés
264
Date d'inscription
dimanche 14 avril 2013
Statut
Membre
Dernière intervention
23 mai 2014
2
Salut Henry
Ben le texte... y en a pas!!!
Comme dit, je ne produis le crash que si je lance directement l'exe. Dans ce cas, crash, popup de windows avec demande d'envoi.
Le contenu de l'envoi :
EventType : clr203r3 P1:Testswriter.exe (nom du prgm) P2: 1.0.0.29453 P3:4e7b528b P4:mscorlib P5:4.0.0.0 P6: 4da3fe76 P7:2603
P8:0 P9:system.io.fileloadexception

J'ai essayé de l'ouvrir via la console, mais il lance simplement l'exe, sans retour. (J'ai juste tapé "Testswriter.exe", faut taper autre chose)

Merci de ton aide.

@+. Hermios