[ASP.NET AjaxToolKit] AutoComplete ne fonctionne pas [Résolu]

Messages postés
58
Date d'inscription
mercredi 25 avril 2007
Dernière intervention
13 septembre 2012
- - Dernière réponse : cs_suzukMan
Messages postés
58
Date d'inscription
mercredi 25 avril 2007
Dernière intervention
13 septembre 2012
- 19 juil. 2011 à 17:50
Bonjour,

Je fais parti des nombreuses personnes rencontrant un pb avec l'ajax tool kit.

J'ai bien cherché et malgré avoir trouver plein de chose, rien ne répond à mon pb à savoir :
PAS D'AUTO-COMPLETION RIEN NE SE PASSE !

Voici mon HTML





Dans mon code behind

[System.Web.Services.WebMethod]
[System.Web.Script.Services.ScriptMethod]
public string[] GetListContact(string prefixText, int count, string contextKey)
{
return new string[] { "toto", "tata", "titi" };
}

Dans ma MASTER PAGE le Scipt Manager




Merci d'avance de votre aide !
Bye

Cordialement
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
58
Date d'inscription
mercredi 25 avril 2007
Dernière intervention
13 septembre 2012
3
Merci
Bonjour,

J'ai mis ma méthode en static et puis ça marche donc problème résolue !

D'après ce que j'ai vu le static est à mettre seulement si on utilise pas de web service

Cordialement

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources a aidé 98 internautes ce mois-ci

Commenter la réponse de cs_suzukMan
Messages postés
6069
Date d'inscription
dimanche 13 avril 2003
Dernière intervention
15 juillet 2011
0
Merci
Salut,

Es-tu en dotnet4.0 ou 3.5 ou 2.0?
As-tu configurer le fichier web.config?
Ta methode appartient-elle a la meme classe?

Si tu utilises le ajaxtoolkitscriptmanager ca change?
Regardes avec une page sans master page si tu un resultat.

Apres avoir regardé et repondu tous ces aspects, il sera plus facile de trouver une piste et une correction du probleme
Commenter la réponse de nhervagault
Messages postés
58
Date d'inscription
mercredi 25 avril 2007
Dernière intervention
13 septembre 2012
0
Merci
Bonjour,

Tout d'abord merci de t'interessé à mon pb.

- Framework : 4.0
- Configuration Web.Config : A priori rien en ce qui concerne l'ajax (Il y a des choses à mettre ??)
- Ma méthode appartient à la classe Behind de mon HTML
- ajaxtoolkitscriptmanager : j'ai testé avec ça ne change rien
- Sans la Master Page : Avec le toolkitScriptManager ou le ScriptManager pas de résultat non plus ...

Voici les réponses attendues.
Merci de ton aide.

Cordialement
Commenter la réponse de cs_suzukMan

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.