Probleme

Résolu
Signaler
Messages postés
6
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
14 juillet 2010
-
Messages postés
6
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
14 juillet 2010
-
Bonjour,

Je fais mon site portfolio et je suis tombé face à un petit problème que je n'arrive pas à résoudre.
Sur ma timeline principale j'utilise 4 images-clefs ..chacune représente une page distincte de mon site (accueil, portfolio,me connaitre, contact).
Sur certaines de ces images clef je fais appel à des swf externes et à des clips avec une profondeur précise (swapDepths).
Seulement lorsque je change d'image clef, les clips externes restent toujours visibles, pareil avec les clips (swapDepths)!

Ya-til une méthode pour résoudre ce problème sachant que si j'utilise un removeMovieClip pour supprimer ces clips dans les autres images-clefs, cela tend à les "buger" sur l'image-clef native !?

3 réponses

Messages postés
6
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
14 juillet 2010

cela ne venait pas de la profondeur de clip mais bel et bien de mes setInterval donc avec des clear tout va mieux !
Messages postés
1671
Date d'inscription
dimanche 6 mars 2005
Statut
Membre
Dernière intervention
21 juillet 2013
4
salut
qu'est ce que tu veux dire par :"si j'utilise un removeMovieClip pour supprimer ces clips dans les autres images-clefs, cela tend à les "buger" sur l'image-clef native !?"

si tes swf et clips restent visibles apres un unloadMovie et un removeMovieClip tu as soit une erreur dans ton script, soit il n'est pas a sa place
tu as controle tes noms d'instances ?
a+
Messages postés
6
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
14 juillet 2010

Avant tout merci de t'intéresser à mon message docodoc...
Pour être plus précis, sur une timeline lorsque l'on insère un clip sur une image clef, nous sommes d'accord que si ce clip n'est pas présent sur l'image clef suivante il n'apparaitra pas, il n'apparaitra que sur celle ou il a été placé...logique

La mon probleme vient du fait qu'en ajoutant une profondeur avec swapDepths, les clips placé sur une image-clef précise vont apparaitre sur les 3 autres images clef !
Par exemple mon arbre de l'accueil va s'invité sur le portfolio, la rubrique me connaitre et la page contact alors qu'à la base il n'a rien à y faire et à juste été placé sur l'accueil !
Alors première question : pourquoi ?

Et donc pour palier à ça je rajoute sur mon image-clef portfolio un removeMovieClip pour que cet arbre n'apparaisse plus sur cette page....
ca fonctionne nickel.
Mais sur la page native càd l'accueil, le clip arbre bug...il ne prend plus en compte mes stop et se joue indéfiniment !
et pour d'autres clips ils se jouent plusieurs fois d'affilé et s'arrêtent brusquement !

Donc rien à voir avec les noms d'instances ou une erreur avec removeMovieClip mais j'ai plus un soucis avec les conséquences des profondeurs que se soit sur les clips ou les swf importés !

Et je ne trouve pas d'explications à ca sur le net ou sur comment fonctionne précisément les profondeurs !
Si vous pouviez m'éclairer ...?