Fichier swf

Signaler
Messages postés
315
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
22 décembre 2014
-
Messages postés
2814
Date d'inscription
mardi 15 avril 2003
Statut
Membre
Dernière intervention
2 juin 2020
-
Bonsoir à tous.

Je me tire les cheveux... En vain...
En visual basic, j'ai programmé un contrôle shockwaveFlash
qui contient un swf.
Sur les postes administrateurs (xp et vista),
cela fonctionne nickel !
Sur les postes non-administrateurs (xp),
cela ne fonctionne plus...
Il y a 1 mois, j'ai installé sur un poste non-administrateur
un swf "PUB.swf" dans un dossier utilisateur "PromoMois"...
Et cela fonctionnait très bien...
J'en ai profité pour recompiler ma source,
vu que des modifications de programme
m'avaient été demandées juste après...

Mais aujourd'hui, en écrasant ce swf par uun autre dans le même dossier,
cela ne fonctionne plus !!!
Pour faire cette manip, j'ai dû passer en mode admin,
pour placer ce swf dans ce dossier...

Pire encore, je remets l'ancine swf...
Lui non plus ne fonctionne plus !!!

C'est un véritable mystère pour moi !!!

Pourquoi ???

- Y a-t-il eu une misa à jour,
Windows ou Adobe, qui cause cela ???
- Est-ce le fait que le "nouveau" swf,
n'est pas été recompilé avec la source Visual Basic ???

Aidez-moi, svp.

5 réponses

Messages postés
315
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
22 décembre 2014

Encore une précision,
sur ce poste non-administrateur,
je n'arrive même plus à lire le swf
via internet explorer 7...
Ceci a-t-il un rapport avec mon problème...

Sur les postes admin, il s'ouvre sous IE7...
Messages postés
2814
Date d'inscription
mardi 15 avril 2003
Statut
Membre
Dernière intervention
2 juin 2020
31
Bonsoir,

Quel message d'erreur as-tu lors de l'ouverture de celui-ci ? Si c'est un problème de droits, alors il faut qu'en mode administrateur tu laisse les droits d'acces au dossier pour les comptes utilisateurs en passant par les proprétés de sécurité de windows.

                                                                              
Si le déboguage est l'art d'enlever les bogues, la programmation doit être l'art de les créer. <
Messages postés
315
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
22 décembre 2014

Je n'ai aucun message...
J'ai une zone flash vide qui ne s'execute pas...
Messages postés
315
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
22 décembre 2014

Peux-tu me dire comment faire
pour modiifer ces propriétés de sécurité?
Messages postés
2814
Date d'inscription
mardi 15 avril 2003
Statut
Membre
Dernière intervention
2 juin 2020
31
Fais un click droit sur le dossier en question puis propriétés et va à l'onglet sécurité, en suite tu as les differents groupes et utilisateurs, click sur le bouton "modifier..." pour paramètrer les autorisation en lecture / erciture etc...

Sous XP il faut désactiver le partage de fichier simple pour avoir l'oglet sécurité me semble-t-il...

@+
                                                                              
Si le déboguage est l'art d'enlever les bogues, la programmation doit être l'art de les créer. <