Accès SQL Server - SSPI [Résolu]

Messages postés
5
Date d'inscription
vendredi 3 février 2006
Dernière intervention
9 avril 2010
- 20 févr. 2009 à 15:26 - Dernière réponse :
Messages postés
5
Date d'inscription
vendredi 3 février 2006
Dernière intervention
9 avril 2010
- 20 nov. 2009 à 12:16
Bonjour,
L'application est un ERP qui accède à la base de données ACCESS.
Suite à une modification de code pour une utilisation possible de la base SQL Server, j'ai des problèmes de connection à la base de données SQL Server.
La liaison à la base de données se fait par la DLL : dao360.dll.
Environnement :    serveur : SBS 2003 SP3 
                            base de donnée origine : ACCESS 2000 
                            base de données : SQL Server 2000 \ SP4 
                            VB6  / SP6

Pour le passage d'une base de données à l'autre, nous effectuons une migration qui se déroule très bien. 
C'est après la migration de la base de données que les choses posent des problèmes.
Si je créée un lien ODBC d'accès à SQL, la liaison ne se fait qu'épisodiquement sans savoir pourquoi ou pourquoi pas.
Mais quand ça se passe mal j'ai le message d'erreur suivant : 
            Echec lors de la connexion :
            Etat SQL : 'S1000'
            Erreur SQL Server : 0
            [Microsoft][ODBC SQL Server driver]Impossible de générer le contexte SSPI

L'utilisation de SQL server pour l'application fonctionne sur un autre site.

Quelqu'un aurait une idée ou aurait été confronté à ce problème ?
Merci d'avance pour la réponse. 
Si ce n'est pas clair, n'hésitez pas à me poser des questions.

cuttysark
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
7745
Date d'inscription
mercredi 1 septembre 2004
Dernière intervention
24 septembre 2014
- 20 févr. 2009 à 21:29
3
Merci
D'après les différentes contributions que l'on trouve sur le net concernant ce problème, il semblerait que tu utilise l'authentification Windows pour te connecter à ton serveur SQL et que celui-ci à parfois du mal à interroger le controleur de domaine de ton réseau pour vérifier l'identité de l'utilisateur de la connection.
C'est donc une piste à vérifier.

Peut-etre peux tu aussi tenter de te connecter en utilisant un login/mot de passe d'un utilisateur SQLServer (sa, par exemple)

---- Sevyc64  (alias Casy) ---- # LE PARTAGE EST NOTRE FORCE #   

Merci cs_casy 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de cs_casy
Meilleure réponse
Messages postés
5
Date d'inscription
vendredi 3 février 2006
Dernière intervention
9 avril 2010
- 24 févr. 2009 à 10:23
3
Merci
J'ai trouvé la réponse au problème.
A l'origine dans la société, il n'y avait pas de serveur mais un petit réseau géré par le routeur.
Donc le routeur faisait office de DHCP.
Avec le routeur qui faisait office de DHCP, de ce fait, les temps de réponse étaient trop longs, ce qui ne permettait pas au
serveur de répondre suffisamment tôt.
Le serveur DHCP a été configuré sur le serveur et maintenant ca fonctionne bien.

Merci pour la rponse.
cuttysark

Merci cuttysark 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 88 internautes ce mois-ci

Commenter la réponse de cuttysark
Messages postés
5
Date d'inscription
vendredi 3 février 2006
Dernière intervention
9 avril 2010
- 23 févr. 2009 à 10:48
0
Merci
Bonjour,
Effectivement, je pense aussi qu'il y a un souci d'authentification entre le contrôleur de domaine et SQL server.

Oui, j'essaie de me connecter par l'authentification Windows avec l'application.
J'ai fait des modifications ( avec les articles Microsoft sur SSPI ) sur le serveur.
La conséquence de ces essais est que l'AD a été inutilisable après (je suppose que ceux sont mes modifications
qui ont mis l'AD HS).

Je vais faire des Tests de connection par SQL.

Par quel moyen puis-je avoir une connection à l'AD stable ?

Merci,
cuttysark
Commenter la réponse de cuttysark
Messages postés
4
Date d'inscription
samedi 27 janvier 2007
Dernière intervention
26 novembre 2009
- 12 nov. 2009 à 11:21
0
Merci
Bonjour
L'application est un ERP qui accède à la base de données sql.
Suite à une modification du nom du poste , j'ai des problèmes de connection à la base de données SQL Server.
l'Erreur SQL Server est
merci de m'aider
[Microsoft][ODBC SQL Server Driver][SQL Server]Echec de la connexion de
l'utilisateur 'APPL' : Erreur SQL Server! SQL Server!


slt
Commenter la réponse de famery
Messages postés
4
Date d'inscription
samedi 27 janvier 2007
Dernière intervention
26 novembre 2009
- 12 nov. 2009 à 11:23
0
Merci
Bonjour
L'application est un ERP qui accède à la base de données sql.
Suite à une modification du nom du poste , j'ai des problèmes de connection à la base de données SQL Server.
l'Erreur SQL Server est
merci de m'aider
[Microsoft][ODBC SQL Server Driver][SQL Server]Echec de la connexion de
l'utilisateur 'APPL' : Erreur SQL Server! SQL Server!


slt
Commenter la réponse de famery
Messages postés
5
Date d'inscription
vendredi 3 février 2006
Dernière intervention
9 avril 2010
- 20 nov. 2009 à 12:16
0
Merci
Bonjour,

Est-ce que la base d'origine est une base SQL server ?
Quelle est la version de la base de donnée ?
L'utilisateur 'APPL' est-il déclaré en tant qu'utilisateur dans la base ?

Cordialement
cuttysark
Commenter la réponse de cuttysark

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.