Couleur sous Vista

cs_tolt Messages postés 270 Date d'inscription mardi 17 décembre 2002 Statut Membre Dernière intervention 4 avril 2019 - 2 févr. 2009 à 15:11
cs_tolt Messages postés 270 Date d'inscription mardi 17 décembre 2002 Statut Membre Dernière intervention 4 avril 2019 - 3 févr. 2009 à 09:06
Bonjour,

J'ai un programme que j'écris avec VB6 sous XP.Jusqye là pas de soucis il tourne impecable...J'install le même programme sous Vista et là surprise.
Il tourne impecable aussi mais j'ai des problèmes de couleurs.
Les font de formes blanc sont noir.Les frames fonts blanc sont noir aussi !

Avez vous la solution sachant encore une fois que je travail et compli sous XP.

Merci

6 réponses

Renfield Messages postés 17287 Date d'inscription mercredi 2 janvier 2002 Statut Modérateur Dernière intervention 27 septembre 2021 71
2 févr. 2009 à 16:46
pas saisi toute la subtilité du souci...

joues tu avec un manifest ? (theme de Windows appliqué aux programmes Vb6)
0
cs_tolt Messages postés 270 Date d'inscription mardi 17 décembre 2002 Statut Membre Dernière intervention 4 avril 2019
2 févr. 2009 à 17:24
J'utilise par exemple sur ma feuille une frame toute simple...Elle est grise en générale dans VB6 cette frame que je viens de déplacer sur ma feuille.
Ensuite cette frame là je lui mais une couleur blanche.

Ben sur Vista elle est noir cette frame alors que sur XP, 2000 etc...elle est bien blanche.

Merci beaucoup  

tolt
0
Renfield Messages postés 17287 Date d'inscription mercredi 2 janvier 2002 Statut Modérateur Dernière intervention 27 septembre 2021 71
3 févr. 2009 à 08:27
j'ai du mal a suivre, une fois de plus...

expliques moi ça comme si j'avais sept ans.
0
cs_tolt Messages postés 270 Date d'inscription mardi 17 décembre 2002 Statut Membre Dernière intervention 4 avril 2019
3 févr. 2009 à 08:45
Renfield t'est surement l'un des plus balaise sur ce site et j'ai du mal à comprendre ce que tu ne comprends pas.

Ouvre sur XP un projet VB6 sur ce projet pas exemple je mais mon objet Form en font blanc ou un objet Frame1.backcolor=&H00FFFFFF&
Je comppile le projet pour en faire un EXE.

Je lance sur XP le projet1.exe sur XP impec...Le même projet1.exe sur Vista ma fenetre ou ma Frame1 son noir....

Renfield en tout cas Merci pour ton aide car là sincérement je séches.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Renfield Messages postés 17287 Date d'inscription mercredi 2 janvier 2002 Statut Modérateur Dernière intervention 27 septembre 2021 71
3 févr. 2009 à 08:59
je testerais ce soir sous Vista.
0
cs_tolt Messages postés 270 Date d'inscription mardi 17 décembre 2002 Statut Membre Dernière intervention 4 avril 2019
3 févr. 2009 à 09:06
OK Merci Renfield.

Encore une fois il faut compiler l'EXE à partir d'XP et le lancer ensuite sous Vista tel que.Vous allez voir le blanc devient noir...

Bonne journée
0