Javascript, les frames et le couple Php/MySql

Signaler
Messages postés
166
Date d'inscription
mercredi 27 juin 2007
Statut
Membre
Dernière intervention
31 mars 2014
-
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
-
Bonjour à tous,
je suis donc toujours sur un projet personnel qui avançait à grand pas (merci aux nombreux contributeurs de ce site).

Un nouvelle étape dans le développement de mon projet m'amène à utiliser une base de données, donc php/mysql pour mon cas (via EasyPhp). Après avoir pas mal cogité, j'ai fini par réaliser un accès pour membres réservés fonctionnel (un membre s'identifie, s'il ne l'est pas il peut s'inscrire => tout est bien enregistré dans la base de données).

Mon idée était qu'une fois la validation du formulaire d'accés achevée, une redirection (forcément via php, corrigez moi si je me trompe) devait s'effectuer vers mon site.
Cependant, notons que ce site est constitué de plusieurs frames, l'une d'elle générant dynamiquement une autre via la fonction:
=>    parent.frame_droite.document.writeln("bla bla bla");

Bref, la redirection semble se faire correctement => mon site apparaît à l'écran, mais lorsque je veux m'en servir: c'est le drame.. Rien ne fonctionne !!
Alors que tout semble nickel lorsque j'execute directement mon code via le navigateur (par un double clic ou l'inscription du chemin d'accès dans la barre d'adresse), le navigateur bug lorsque je tente d'executer un script lorsque le site a été appelé après validation par php d'un formulaire.

Ca parait peut-être confus, mais pour résumer le problème: tout fonctionne quand code interprété directement côté client, rien ne fonctionne interprété côté serveur, le navigateur se fige et je dois le fermer par un Ctrl+Alt+Suppr (à priori je ne veux même pas qu'il soit interprété côté serveur, juste qu'il soit chargé bêtement côté client dans le navigateur)

Je n'y comprends rien. En effet, je pensais que le serveur Apache installé en local avec EasyPhp, allait bêtement transmettre tout ce qui n'est pas du php au navigateur (donc tout mon code en fait), et puisque tout fonctionne avec celui-ci, tout serait simple et logique et FONCTIONNEL et ......

Mais non, je bloque carrément, sans savoir pourquoi.

Bref, voilà mes pseudo questions:
Quelqu'un a-t-il une idée quant au pourquoi du comment de cela ?
N'y aurait-il pas un moyen d'appeler mon site directement par le navigateur après la validation du formulaire par un script php (la fonction Php  header("Location: monsite_en_local.htm")  est celle appelant mon site) ??

Avez-vous été confronté à des soucis du même type ? Si oui, comment les avez-vous résolus ?
J'ai bien d'autres questions encore, mais chaque chose en son temps

Voilà, en espérant vos précieux éclaircissement.
Merci d'avance, et à bientôt

Signé Sagat

1 réponse

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
34
>>Ca parait peut-être confus,
un peu.

>>tout fonctionne quand code interprété directement côté client,
>>rien ne fonctionne interprété côté serveur
alors probablement des erreurs sur les noms
des "fichiers"
sur un site, généralement ( unix oblige ), les
majuscules/minuscules sont signifacatifs, pas
en local ( ou sur un site ) si tu es sous windows.

>> Si oui, comment les avez-vous résolus
sans le moindre petit bout de code, ou l'url pour voir...
on va avoir du mal pour t'aider plus
( quoique, il y a des gars qui arrivent
à deviner )

@+