Problème d'imbrication : animation/code actionscript

Signaler
Messages postés
3
Date d'inscription
jeudi 24 août 2006
Statut
Membre
Dernière intervention
25 août 2006
-
Messages postés
3
Date d'inscription
jeudi 24 août 2006
Statut
Membre
Dernière intervention
25 août 2006
-
Bonjour à tous !



<!--[if !supportEmptyParas]-->Avant toute chose il est bon de préciser que je suis une
chèvre en flash, donc ne soyez pas trop étonné…



<!--[if !supportEmptyParas]-->
<!--[endif]--> Bon, ca c’est fait,  voyons
maintenant ce qu’il se passe :



<!--[if !supportLists]-->-        
<!--[endif]-->J’ai crée un swf que j’ai intégré à un fichier html. (jusque
là tout va bien)



<!--[if !supportLists]-->-        
<!--[endif]-->Le fla dont il découle, est en fait une animation sur 60
images (en gros une sorte d’oiseau virevolte de droite à gauche pendant que les
nuages se bercent au gré du vent ). Pour créer cette animation que je fais lire
en boucle, j’ai simplement utilisé les interpolations de mouvements et de
formes (et il y a des chances que mon problème viens de là, vous allez voir…)



<!--[if !supportLists]-->-        
<!--[endif]-->Après cela, j’ai voulu insérer un texte autodéfilant du bas
vers le haut. Grâce à CHERIO (un utilisateur de ce site), j’ai réussi à
intégrer un code qui me permet de faire ceci. Je me suis donc largement basé du
tuto que vous pourrez trouver : ici.



<!--[if !supportEmptyParas]--> <!--[endif]-->

Maintenant mon soucis est le suivant : quand on ouvre
la page tout va bien pour commencer, mais très rapidement (dès que l’animation
a lue les 60 images, enfin je suppose) mon texte autodéfilant qui n’a pas le
temps de défiler en entier, se recharge et accélère de plus en plus, si bien
qu’au final seul des gens tel Steve Austin ou Superman doivent être capable de
me lire…


Je pense que mon problème vient de la combinaison code (texte autodefilant) / animation
(oiseau + nuages) qui ne sont pas synchro.


Je voudrais donc savoir comment je dois m’y prendre ?


D’avance un grand merci à tous ceux qui se pencheront sur
mon cas !


Vous pouvez voir la page html en question : ici.


Nico



<!--[if !supportEmptyParas]--> <!--[endif]-->

2 réponses

Messages postés
3
Date d'inscription
jeudi 24 août 2006
Statut
Membre
Dernière intervention
25 août 2006

Non?
Personne aurait une petite idée??
Une petite piste???
Un lien????

Je veux pas saouler, je suis très content d'apprendre par moi-même, mais sur ce coup-là j'ai vraiment besoin d'un petit coup de pouce pour relancer la machine...

Merci les gens!

nico
Messages postés
3
Date d'inscription
jeudi 24 août 2006
Statut
Membre
Dernière intervention
25 août 2006

"Aide-toi et le ciel t'aideras"

Bon j'ai trouvé ce qui déconnait, tout seul (avec peut etre une intervention divine, mais ca je peux pas le prouver). En fait, il fallait pas que je fasse l'animation des éléments du décor sur le plan du travail mais que j'en fasse des "movie clips"!!