Pb avec buttonMode (as3) et champ texte dynamique [Résolu]

Messages postés
619
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
27 août 2010
- - Dernière réponse : cs_inaden
Messages postés
619
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
27 août 2010
- 21 sept. 2009 à 11:22
Bonjour à tous,

voilà, j'ai un pb stupide ! J'ai un clip composé de deux images-clé sur un calque, et d'un champ texte dynamique recouvrant (en une seule image clé) les deux images clés du dessous et qui se trouve sur un calque au dessus.
Je distribue les intitulés de mes rubriques dans ce champs texte.
J'essaie d'attribuer un buttonMode = true à mes clip mais le champ texte dynamique empêche cela de fonctionner.
Deux preuves : lorsque que je supprime le champ texte... ça marche
si je ne le supprime pas, la petite zone non recouverte par le champ texte dynamique fonctionne en "mode bouton".
Que le champs texte soit selectionnable (ce qui n'est pas terrible)ou pas, cela revient au même.

Si quelqu'un a une idée...
Merci d'avance


Tout vient à qui sait attendre
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
619
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
27 août 2010
2
3
Merci
J'ai eu la réponse sur un autre forum :
tonTexte.mouseEnabled = false;
nimporteQuelInteractiveObject.mouseEnabled = false;


Tout vient à qui sait attendre

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 191 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_inaden