UAC Vista - requireAdministrator et lancement au démarage

cs_SuperChouquette Messages postés 37 Date d'inscription dimanche 24 février 2008 Statut Membre Dernière intervention 18 mai 2010 - 20 févr. 2009 à 10:49
SebLinck Messages postés 212 Date d'inscription mardi 17 mai 2005 Statut Membre Dernière intervention 23 juin 2011 - 20 févr. 2009 à 14:22
Bonjour, j'ai créer un petit programme en c++ qui à besoin de se lancer au démarrage.
Pour cela quand le programme se lance il vérifie si il est déjà inscrit dans le registre si il ne l'est pas il s'inscrit.
Mais pour s'inscrire dans le registre le programme à besoin des droits administrateur, j'ai donc fait un manifest avec <requestedExecutionLevel level='requireAdministrator' />

mais le problème est que l'UAC de windows bloque le lancement des programme au démarrage nécessitant une élévation de privilège.

Merci !

3 réponses

cs_SuperChouquette Messages postés 37 Date d'inscription dimanche 24 février 2008 Statut Membre Dernière intervention 18 mai 2010
20 févr. 2009 à 10:51
Sinon il faudrait que le programme demande une élévation uniquement lors de l'acces à la base de registre...
0
cs_SuperChouquette Messages postés 37 Date d'inscription dimanche 24 février 2008 Statut Membre Dernière intervention 18 mai 2010
20 févr. 2009 à 13:16
Désolé je me suis trompé ce n'était en fait pas l'acces au registre qui nescessitait une élévation mais autre chose ..
0
SebLinck Messages postés 212 Date d'inscription mardi 17 mai 2005 Statut Membre Dernière intervention 23 juin 2011
20 févr. 2009 à 14:22
Salut,
Si tu pouvais expliquer..
Le forum ne fonctionne pas à sens unique ..

Cordialement,
Sébastien.
0