Problème d'autorisation

Signaler
Messages postés
353
Date d'inscription
samedi 11 décembre 2010
Statut
Membre
Dernière intervention
29 juin 2011
-
Messages postés
11
Date d'inscription
mercredi 8 juillet 2009
Statut
Membre
Dernière intervention
27 août 2010
-
Bonjour à tous.
Voila je suis en train de créer un site web et j'utilise visual studio 2008.
Dans mon site j'ai créer une page "Administrateur".
Je voudrais que cette page ne puisse s'afficher que lorsque l'on est connecté en administrateur.
Pour cela j'ai utilisé l'outil de configuration de site web de visual studio et j'ai créer des règles d'accès.
Jusque là tous va bien mais sa ne marche pas , meme si je me connecte en administrateur il ne me reconnais pas.
De plus j'ai ajouter ce code :<meta http-equiv= "Content-Type" content="text/html; charset=utf-8" /><meta name="ProgId" content="Word.Document" /><meta name="Generator" content="Microsoft Word 11" /><meta name="Originator" content="Microsoft Word 11" /><link rel="File-List" href="file:///C:%5CDOCUME%7E1%5Chugo%5CLOCALS%7E1%5CTemp%5Cmsohtml1%5C01%5Cclip_filelist.xml" /><!--[if gte mso 9]><xml>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:HyphenationZone>21</w:HyphenationZone>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
</w:Compatibility>
<w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel>
</w:WordDocument>
</xml><![endif]--><!--[if gte mso 9]><xml>
<w:LatentStyles DefLockedState="false" LatentStyleCount="156">
</w:LatentStyles>
</xml><![endif]--><style><!--
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{mso-style-name:"Normal\,13 pt";
mso-style-parent:"";
margin:0cm;
margin-bottom:.0001pt;
text-align:justify;
mso-pagination:widow-orphan;
font-size:10.0pt;
mso-bidi-font-size:12.0pt;
font-family:Arial;
mso-fareast-font-family:"Times New Roman";
mso-bidi-font-family:"Times New Roman";}
@page Section1
{size:612.0pt 792.0pt;
margin:70.85pt 70.85pt 70.85pt 70.85pt;
mso-header-margin:36.0pt;
mso-footer-margin:36.0pt;
mso-paper-source:0;}
div.Section1
{page:Section1;}
--></style><!--[if gte mso 10]>
<style>
/* Style Definitions */
table.MsoNormalTable
{mso-style-name:"Tableau Normal";
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-parent:"";
mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
mso-para-margin:0cm;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:10.0pt;
font-family:"Times New Roman";
mso-ansi-language:#0400;
mso-fareast-language:#0400;
mso-bidi-language:#0400;}
</style>
<![endif]--><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026"/>
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1"/>
</o:shapelayout></xml><![endif]-->

<siteMap>

       

          <remove
name="AspNetXmlSiteMapProvider"/>

         
    securityTrimmingEnabled="true"
siteMapFile ="Web.sitemap"/>

       

</siteMap>

Pour que le menu s'adapte en fonction de qui est connecter mais lorsque je met ce code le menu disparait.

Voila d'avances merci pour vos réponses.

6 réponses

Messages postés
6063
Date d'inscription
dimanche 13 avril 2003
Statut
Modérateur
Dernière intervention
15 juillet 2011
31
Messages postés
353
Date d'inscription
samedi 11 décembre 2010
Statut
Membre
Dernière intervention
29 juin 2011

Merci pour ta réponse nhervagault , j'ai essayer ce qu'il dise mais sa ne marche toujours pas.
Messages postés
353
Date d'inscription
samedi 11 décembre 2010
Statut
Membre
Dernière intervention
29 juin 2011

J'ai suivi le coach asp de microsoft mais pareil sa ne marche pas.
Messages postés
353
Date d'inscription
samedi 11 décembre 2010
Statut
Membre
Dernière intervention
29 juin 2011

J'ai du nouveau.
Les règles d'accès marche mais ce qui ne marche pas et qui foire tous ces que le menu ne s'adapte pas en fonction de l'utilisateur.
Pour cela il faut ajouter le code :

<siteMapenabled="true"defaultProvider="XmlSiteMapProvider">
<providers>
<addname="XmlSiteMapProvider"
type="System.Web.XmlSiteMapProvider"
siteMapFile="Web.sitemap"securityTrimmingEnabled="true"/>
</providers>
</siteMap>

Dans le web.config

Le problème ces que lorsque je le fais mon menu disparait.
Messages postés
353
Date d'inscription
samedi 11 décembre 2010
Statut
Membre
Dernière intervention
29 juin 2011

Je vous donne le code de mon web.config car j'ai peut-être mal placé le code :

<?xml version="1.0"?>
<!--
    Remarque : au lieu d'éditer manuellement ce fichier, vous pouvez utiliser
    l'outil d'administration Web pour configurer les paramètres de votre
    application. Utilisez l'option Site Web->Configuration Asp.Net de Visual Studio.
    Vous trouverez la liste complète des paramètres et commentaires dans
    machine.config.comments, situé généralement dans
    \Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
  <configSections>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
          <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
        </sectionGroup>
      </sectionGroup>
    </sectionGroup>
  </configSections>
 
  <connectionStrings>
   
   
   
  </connectionStrings>
  <system.web>
    <siteMap enabled="true" defaultProvider="XmlSiteMapProvider">
     
       
     

    </siteMap>

    <!--
            Définissez compilation debug="true" pour insérer des symboles
            de débogage dans la page compilée. Comme ceci
            affecte les performances, définissez cette valeur à true uniquement
            lors du développement.

            Options Visual Basic :
            Définissez strict="true" pour interdire les conversions de types de données
            susceptibles d'entraîner des pertes de données.
            Définissez explicit="true" pour forcer la déclaration de toutes les variables.
        -->
   
   
   
   
    <roleManager enabled="true" />
    <compilation debug="true" strict="false" explicit="true">
     
       
       
       
       
     
    </compilation>
   
      <namespaces>
        <clear/>
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
      </namespaces>
      <controls>
       
       
      </controls>
   

    <!--
            La section permet la configuration
            du mode d'authentification de sécurité utilisé par
            ASP.NET pour identifier un utilisateur entrant.
        -->
   
    <membership defaultProvider="MyProvider">
     
       
     

    </membership>
    <!--
  
   
            La section <customErrors> permet de configurer
            les actions à exécuter si/quand une erreur non gérée se produit
            lors de l'exécution d'une demande. Plus précisément,
            elle permet aux développeurs de configurer les pages d'erreur html
            pour qu'elles s'affichent à la place d'une trace de la pile d'erreur.

        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
    <httpHandlers>
      <remove verb="*" path="*.asmx"/>
     
     
     
    </httpHandlers>
    <httpModules>
     
    </httpModules>
  </system.web>
  <system.codedom>
    <compilers>
      <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
       
       
      </compiler>
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
       
       
       
      </compiler>
    </compilers>
  </system.codedom>
  <!--
        La section system.webServer est requise pour exécuter ASP.NET AJAX sur Internet
        Information Services 7.0.  Elle n'est pas nécessaire pour les versions précédentes d'IIS.
    -->
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <modules>
      <remove name="ScriptModule"/>
     
    </modules>
    <handlers>
      <remove name="WebServiceHandlerFactory-Integrated"/>
      <remove name="ScriptHandlerFactory"/>
      <remove name="ScriptHandlerFactoryAppServices"/>
      <remove name="ScriptResource"/>
     
     
     
    </handlers>
  </system.webServer>
  <runtime>
   
      <dependentAssembly>
       
       
      </dependentAssembly>
      <dependentAssembly>
       
       
      </dependentAssembly>
   
  </runtime>
</configuration>
Messages postés
11
Date d'inscription
mercredi 8 juillet 2009
Statut
Membre
Dernière intervention
27 août 2010
1
Bonjour,
j'ai le même problème que vous avez rencontrez concernant les règles d'accès, alors si vous pouvez m'expliquer comment s'en sortir.
merci