Problème HtmlEncode [Résolu]

Messages postés
4
Date d'inscription
vendredi 9 février 2007
Dernière intervention
25 février 2008
- - Dernière réponse : sebmafate
Messages postés
4947
Date d'inscription
lundi 17 février 2003
Dernière intervention
14 février 2014
- 10 janv. 2008 à 15:24
Bonjour,

Je suis en train de développer un petit programme dans lequel j'utilise la méthode HtmlEncode de la classe HttpUtility pour convertir les caractères spéciaux (é, &, à, ê, ...).
Mon problème c'est qu'il me les convertit en entité numérique et pas en entité html, pour le "é" j'obtiens "& # 2 3 3 ;" (sans les espaces) alors que je souhaiterais plutôt avoir "& e a c u t e ;" (sans les espaces).
Est-ce que quelqu'un saurai résoudre mon problème, ça serait sympa.

Merci d'avance
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
4947
Date d'inscription
lundi 17 février 2003
Dernière intervention
14 février 2014
54
3
Merci
Salut,

En fait, les solutions sont bonnes... mais Microsoft à fait le choix de transformer les caractères dans leur équivalent Unicode.
Donc, si tu veux obtenir des ´ il faudra que tu te redéveloppes une méthode HtmlEncode.

Sébastien FERRAND (blog)
Consultant Indépendant
[Microsoft Visual C# MVP]

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 121 internautes nous ont dit merci ce mois-ci

Commenter la réponse de sebmafate

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.