Analyseur de spectre as3

Soyez le premier à donner votre avis sur cette source.

Vue 9 847 fois - Téléchargée 937 fois

Description

Exemple d'utilisation de la fonction computeSpectrum d'AS3. Le spectre est calculé à partir de computeSpectrum, puis deux traitements sont effectués: une décimation pour lisser le spectre et une moyenne de plusieurs spectre pour l'effet mémoire.

DEMO http://toto2012.cfun.fr/spectrumdemo.htm

Codes Sources

A voir également

Ajouter un commentaire

Commentaires

sebastien247
Messages postés
27
Date d'inscription
mercredi 16 mai 2007
Statut
Membre
Dernière intervention
13 mars 2011
-
Désolé, en fait le décalage ce produit au moment de tester la l'anim (ctrl + entrée) en la publient il n'y a plus de décalage.
gremlins7
Messages postés
380
Date d'inscription
mardi 29 avril 2003
Statut
Membre
Dernière intervention
28 décembre 2009
-
Je viens de retester d'après le lien de demo fourni, je n'ai aucun décalage. Il y a un arrêt en plein milieu de la chanson de test (choisie d'ailleurs pour ça) et le spectre est synchrone. Peut-être que le problème vient de ton PC ?!!
sebastien247
Messages postés
27
Date d'inscription
mercredi 16 mai 2007
Statut
Membre
Dernière intervention
13 mars 2011
-
Il y a un gros décalage entre ton spectre et le MP3.
J'ai tester plusieurs sources et le problème et le même partout.
Le spectre démarre quelques seconde avant le MP3

Y a t'il une maniere de d'ajouter un décalage manuel au MP3 ?

Merci
cs_aladino
Messages postés
4
Date d'inscription
mardi 26 octobre 2004
Statut
Membre
Dernière intervention
15 avril 2009
-
merci
est ce que il y a klk1 ki pe m'aidé pour faire un histogramme d'une tableau
chui débutant
merci
cs_cd59
Messages postés
72
Date d'inscription
lundi 19 janvier 2004
Statut
Membre
Dernière intervention
31 octobre 2011
-
Cool comme source.
J'ai une petite question : dans ton spectrum.as, j'ai rajouté :

var resulta = Values.slice(1,2);
if(resulta>4){
leclip.play();
} else {
leclip.gotoAndStop(1);
}

leclip se situe dans le fla sur la premiere frame.
Le problème c'est que j'ai un message d'erreur. Le .as ne trouve pas leclip. J'ai essayé avec _parent et _root, mais ca ne marche pas.

Je suis nul en communication entre un .as et un swf. Quelqu'un a une idée ?
Merci.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.