Click and go 3d

Soyez le premier à donner votre avis sur cette source.

Vue 24 079 fois - Téléchargée 3 440 fois

Description

Bonjour, voici une petite demo du principe de "click and go" dans un envorinement 3d. Le principe est simple on clique sur l'ecran pour deplacer le personnage. Ce qui est plus complexe c'est de trouver les coordonnées de ce point en 3d. Le code demontre comment y parvenir avec un seul plan.

Conclusion :


Vous noterez tout de même les petits bonus comme le personnage animé, la boucle de jeux optimisé et quelques commentaires...

B@nne prog

Codes Sources

A voir également

Ajouter un commentaire Commentaires
Messages postés
1
Date d'inscription
vendredi 17 septembre 2010
Statut
Membre
Dernière intervention
17 septembre 2010

un grand merci à Ebartsoft,vraiment du beau travail,bravo
Messages postés
78
Date d'inscription
lundi 13 mai 2002
Statut
Membre
Dernière intervention
4 mai 2008

Vraiment magnifique !
Je cherchais justement à bien gérer le click en 3D.
Es-tu d'accord pour que je me serve de ton moteur 3D pour un petit projet de jeu ?

Je regarde les sources, voir si j'arrive a bien piger comment tout est géré. :)
Encore une fois vraiment bien foutu.

--------------
PS: Il ne fonctionnait pas qd je l'ai téléchargé. J'ai juste fait la modification donnée par TBBUIM1. J'ai ajouté les API manuellement dans MdlDirectX.bas en tout premier (avant tout le code source) :

Public Declare Function GetClientRect Lib "user32" _
(ByVal hwnd As Long, lpRect As RECT) As Long

Public Declare Function SetRect Lib "user32" ( _
lpRect As RECT, _
ByVal X1 As Long, _
ByVal Y1 As Long, _
ByVal X2 As Long, _
ByVal Y2 As Long) As LONG
Messages postés
15
Date d'inscription
samedi 10 mars 2007
Statut
Membre
Dernière intervention
17 mars 2009

ok c'est bom pour dx7 mais a present j'ai la texture du sol et du bonhomme en noir! Pourquoi?
Messages postés
15
Date d'inscription
samedi 10 mars 2007
Statut
Membre
Dernière intervention
17 mars 2009

j'ai un petit probleme avec dx7 lors de la creation de l'objet activeX j'ai l'erreur > "le composant activeX ne peut creer l'objet", Pourquoi?
config > Vista avec gforce 8600gt en dx10
Messages postés
4525
Date d'inscription
dimanche 29 septembre 2002
Statut
Modérateur
Dernière intervention
22 avril 2019
9
Pour soulagé le cpu de toute facon on a pas besoin de plus de 70 fps. Un cpu qui tourne a 100% tout le temps c'est mauvais pour les calcule. tu peux tout a fait le retirer, je conseil de le laisser...
Afficher les 31 commentaires

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.