Struts

mkawti Messages postés 13 Date d'inscription mercredi 16 mai 2007 Statut Membre Dernière intervention 12 juin 2007 - 31 mai 2007 à 14:50
mkawti Messages postés 13 Date d'inscription mercredi 16 mai 2007 Statut Membre Dernière intervention 12 juin 2007 - 31 mai 2007 à 19:43
je prépare mon projet de fin d'etude avec struts ,mon probléme c'est que je veux faire la validation de mon formulaire coté client, j'ai fait un code avec javascripts et il marche bien (kon les champs sont vide ils affiche des messages d'erreur)
mais kont tout les champs sont remplie je click sur le bouton valider=> la requéte n'est pas envoyé


je ne sais pas koi faire pour ke la requéte s'envoie et ke l'application paass autraitement


 

2 réponses

super_toinou Messages postés 764 Date d'inscription mardi 25 mai 2004 Statut Membre Dernière intervention 8 mars 2011 7
31 mai 2007 à 15:46
Yopla,

regardes si le page s envoie ou pas !! Regarde aussi dans ton form sur quelle action ca pointe et surtout si t as mis .do a la fin (le serveur en générale wrappe les *.do pour etre sur regardes ton web.xml)

++ Toinou
0
mkawti Messages postés 13 Date d'inscription mercredi 16 mai 2007 Statut Membre Dernière intervention 12 juin 2007
31 mai 2007 à 19:43
j'ai réussi a resoudre mon probléme la requétte s'envoie et le traitement su elle se fait avec succés
le nouveau probléme maint c'est ke avant kon un champ est vide il affiche un message d'erreur et reste sur la méme page sans envoyé la requéte maint il affiche le message d'erreur mais envoie la requéte pour kel soit traiter  et m'affiche aprés une pagne blanch XXX.do
je ne sais pas pourkoi
est ce ke vous pouvez m'aider
0