Vista beta 2 et .net 3.0, comment programmer ça?

Signaler
Messages postés
475
Date d'inscription
jeudi 19 juin 2003
Statut
Membre
Dernière intervention
3 novembre 2008
-
Messages postés
475
Date d'inscription
jeudi 19 juin 2003
Statut
Membre
Dernière intervention
3 novembre 2008
-
Bonjour,
Je viens d'installer Windows Vista beta 2.
J'ai voulu télécharger C# Express Edition pour m'y mettre à la programmation .net 3.0 mais j'ai des questions.
Sur le site de Microsoft, on dit qu'avant d'installer C# Express Edition, on doit impérativement désinstaller toute version de .net.

Bon, je fais quoi moi pour débuter la programmation WinFX (.net 3.0) sur Windows Vista?

[:D] @++

3 réponses

Messages postés
4936
Date d'inscription
lundi 17 février 2003
Statut
Modérateur
Dernière intervention
14 février 2014
37
pour faire du WinFX... il te faut une autre version de Visual Studio je crois... il faut que tu sois capable de faire du XAML...

Je te conseille de télécharger Microsoft Expression Interactive Designer... http://www.microsoft.com/products/expression/en/default.mspx

Sébastien FERRAND (
blog)
Consultant Indépendant
[Microsoft MVP Visual C#]
Messages postés
794
Date d'inscription
vendredi 24 septembre 2004
Statut
Membre
Dernière intervention
19 août 2008
10
Tout dépend de ce que tu veux utiliser de WinFx :

- Pour WPF, en effet comme le conseille sebmafate, installe aussi Expression (mais garde Visual Studio).
- Pour le reste (WCF, WF, Linq, etc) Visual Studio suffit.

Par contre, il te faut aussi télécharger
- les derniers runtimes (1 pour WCF, 1 pour WPF, etc il me semble)
- le SDK WinFX qui va avec.

Ensuite, il peut y avoir des spécifités pour chaque API, avec parfois des procédures d'install pas toujours évidentes (par exemple pour faire marcher Linq sur une VF...). Attention aussi aux compatibilité entre les versions de runtime et de SDK...

J'ai juste un petit doute quand même, je ne sais pas si tout ca tournera avec les version Express...
Messages postés
475
Date d'inscription
jeudi 19 juin 2003
Statut
Membre
Dernière intervention
3 novembre 2008
1
J'ai juste installer C# Express Edition et une extension (Orcas) et tout fonctionne bien.
Par contre, je fus incapable d'installer MS SQL server express mais c'est pas grave pour le moment.
Merci à vous deux pour vos réponses.

[:D]
@++