Echo avec imagecreatefromjpeg ??

Signaler
Messages postés
10
Date d'inscription
lundi 30 décembre 2002
Statut
Membre
Dernière intervention
12 juillet 2005
-
Messages postés
10
Date d'inscription
lundi 30 décembre 2002
Statut
Membre
Dernière intervention
12 juillet 2005
-
Bonjour,

J'ai ce bout de code qui fonctionne à merveille:

$image imageCreateFromJpeg("la_map.jpg");	$colorCyan imageColorAllocate$image,0,255,255);
imagearc($image, 320,480, 6, 6, 0, 360, $colorCyan);
header("Content-type: image/jpeg");
imagejpeg($image);


Cependant, si je fait un echo AVANT les 5 lignes, imagejpeg() me retourne plein de caractere indésirable (comme si j'ouvrais le .jpg avec un éditeur texte). De plus, si je fait un echo APRES les 5 lignes, l'echo semble ne pas etre prit en concideration.

J'essaie de faire du mappage dynamique qui réagie avec des evenement dhtml. L'image doit etre modifier avec imagearc() dépendement de quel lien de l'image map l'utilisateur clique.

Si quelqu'un sait comment je pourrais regler ce problème afin de pouvoir utiliser des echo (ou autre) pour gerer mon html, votre aide serait très apprécié!

Merci!

2 réponses

Messages postés
358
Date d'inscription
vendredi 1 novembre 2002
Statut
Membre
Dernière intervention
5 septembre 2006

On vient d’avoir le meme problème.
Il faut mettre ton code de génération de l’image dans image.php
Et dans la page ou tu veux utiliser l’image tu fais
Et derrière tu reprends ton code html ou php comme tu veux
voila notre prob résolu

---Perig---
Pour vous servir 8-)
Et parfois en galère :blush)
Souvent même :)
Messages postés
10
Date d'inscription
lundi 30 décembre 2002
Statut
Membre
Dernière intervention
12 juillet 2005

Ca fonctionne! Merci beaucoup!!

Je dois un peu revoir la logique de la page mais rien de bien grave!

Encore merci!
Aurevoir
PsYk0-PaT