Fusionner deux fichiers INI

Soyez le premier à donner votre avis sur cette source.

Snippet vu 15 841 fois - Téléchargée 7 fois

Contenu du snippet

PROCEDURE FusionneINI(sINISource, sINIDestination)
// sINISource : Chemin du fichier .INI qui sera copié dans la destination
// sINIDestination : Chemin du fichier .INI qui recevra le fichier source
// Aprés traitement sINIDestination a son contenu initial et en plus celui de sINISource
// Si une entrée est commune, c'est celle de sINISource qui est conservée au final
// Si sINIDestination est vide ou inexistant, il deviendra sINISource

sListeSectionSource, sSection sont des chaines
sListeMotcleSource, sMotCle sont des chaines

sListeSectionSource = INILit("","","", sINISource)
POUR TOUTE CHAINE sSection DE sListeSectionSource SEPAREE PAR RC
 sListeMotcleSource = INILit(sSection, "", "", sINISource)
 POUR TOUTE CHAINE sMotCle DE sListeMotcleSource SEPAREE PAR RC
    SI sSection <> "" ET sMotCle <> "" ALORS
       INIEcrit(sSection, sMotCle, ...
             INILit(sSection, sMotCle, "", sINISource),...
             sINIDestination)
    FIN
 FIN
FIN


Compatibilité : Windev

Disponible dans d'autres langages :

A voir également

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.