Bizarre : MsDatGrd.Ocx ne marche pas sans MS Office ?

Signaler
Messages postés
3
Date d'inscription
mardi 29 octobre 2002
Statut
Membre
Dernière intervention
29 octobre 2002
-
Messages postés
3
Date d'inscription
mardi 11 mai 2004
Statut
Membre
Dernière intervention
12 mai 2004
-
Hello !

Ca en être un problème de chez bizarre. J'ai une appli VB6 avec un DataGrid issu de MSDatGrd que j'installe partout, tout se passe bien tant que ... le client a déjà installé Office dessus ! Sinon, mon contrôle ne s'affiche pas et les connexions ADO ODBC ne fonctionnent plus.

Si j'installe MS Office, miracle, mon contrôle se comporte normalement. L'ennui, c'est que je ne peux pas imposer MS Office à mon client. Les Dlls sous System32 sont pareilles, idem les OCX (j'ai utilisé Windiff, j'avais recopié System32 avec Word sous un autre rep). Je me prends la tête depuis plusieurs jours la-dessus. A priori, MDAC_TYPE a bien été exécuté à l'installe (Installshield, mon installe VB plantait chez mon client).

Des idées, des tuyaux, un pb connu ? Merci de votre contribution

1 réponse

Messages postés
3
Date d'inscription
mardi 11 mai 2004
Statut
Membre
Dernière intervention
12 mai 2004

Salut Les Amis
Pour moi je developpe une application vb6.0 tout ce passe bien à mon poste ,
le probleme et comme ça lorsque j'installe l'application sur un autre poste ça marche bien sauf quand j'utilise l'evenement KeyDown une erreur survenu me dire
que msdatgrd.ocx ne fonctionne pas correctement et apres l'application se ferme automatiquement.
Vous pouvez m'aider à trouver un solution Merci.
[mailto:Badr_Cool@yahoo.fr Badr_Cool@yahoo.fr]
0