Problème avec WAMP (mysql) [Résolu]

nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 26 juil. 2008 à 15:59 - Dernière réponse : nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention
- 27 juil. 2008 à 13:02
Salut,

J'ai un problème avec mysql depuis deux mois, j'avais déja posté un sujet mais je n'avais eu aucune réponses qui m'ont aidé a résoudre mon problèmes...

En fait phpmyadmin marche bien mais quand je veus me connecter a mysql avec les fonction php :

- mysql_connect();
- mysql_select_db();

Et j'ai les messages d'erreurs suivants :

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\wamp\www\livre_dor_V2\include\config.inc.php on line 14

Warning: mysql_select_db() [function.mysql-select-db]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\wamp\www\livre_dor_V2\include\config.inc.php on line 15

Warning: mysql_select_db() [function.mysql-select-db]: A link to the server could not be established in C:\Program Files\wamp\www\livre_dor_V2\include\config.inc.php on line 15

Warning: filesize() [function.filesize]: stat failed for Resource id #5 in C:\Program Files\wamp\www\livre_dor_V2\include\fonctions.inc.php on line 4

Warning: fread() [function.fread]: Length parameter must be greater than 0 in C:\Program Files\wamp\www\livre_dor_V2\include\fonctions.inc.php on line 4

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\wamp\www\livre_dor_V2\index.php on line 23

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in C:\Program Files\wamp\www\livre_dor_V2\index.php on line 23

Les erreurs en bleu sont généré par les erreurs rouges, comment puis je faire pour que la connection marche ?

J'ai vérifié que les identifiants était corect une centaine de fois dans le fichier config.inc.php...

Merci d'avance !

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Afficher la suite 

Votre réponse

14 réponses

Meilleure réponse
Evangun 1982 Messages postés dimanche 20 février 2005Date d'inscription 24 septembre 2012 Dernière intervention - 27 juil. 2008 à 12:59
3
Merci
Ben dans l'absolu le my.ini et php.ini ont leur importance pour configurer l'accès au serveur mysql, mais si tu me dis que phpmyadmin fonctionne bien, c'est probablement que le pb vient d'ailleurs...

Non pas de tuto sur les named pipes, mais de toute façon il n'y a rien à savoir de plus que ce que je t'ai dit. Mettre un named pipe, ça veut juste dire désactiver les connexions par tcp pour mysql et remplacer localhost par . dans le php.ini, afin d'empêcher qu'un mec puisse se connecter à ton serveur mysql depuis internet.

Bon, réinstalle wamp et ça ira, pour ma part je ne pense pas pouvoir t'aider plus.

Merci Evangun 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 70 internautes ce mois-ci

Commenter la réponse de Evangun
Evangun 1982 Messages postés dimanche 20 février 2005Date d'inscription 24 septembre 2012 Dernière intervention - 26 juil. 2008 à 17:02
0
Merci
Salut,

phpmyadmin arrive à se connecter à mysql, lui ? ou il t'affiche aussi une erreur

s'il se connecte, je pense que tu es bon pour révérifier encore tes identifiants, si c'est bien le bon fichier de connexion que tu inclus et qu'il est réellement inclus, etc.

à+
Commenter la réponse de Evangun
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 26 juil. 2008 à 18:14
0
Merci
Salut Evangun,

Oui, phpmyadmin il se connecte bien a mysql lui et sans afficher d'erreur !

J'ai revérifier mes identifiants mais c'est toujours pareil il n'y avait pas d'erreur dans les identifiant ('localhost', 'root','')...

C'est bien le bon fichier de connection et il est réellement inclus...

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
Evangun 1982 Messages postés dimanche 20 février 2005Date d'inscription 24 septembre 2012 Dernière intervention - 26 juil. 2008 à 18:53
0
Merci
Mmmh... juste avant ta requête, ajoute le code de connexion (pas avec un include, pour de vrai) et dis voir si ça marche. Ca devrait t'aider à trouver l'erreur je pense.
Commenter la réponse de Evangun
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 26 juil. 2008 à 19:26
0
Merci
ok, j'essai et je te dit ce que ça fait ou si c'est pareil...

Il me semble que j'avais déja essayé et que c'était pareil !

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 26 juil. 2008 à 19:32
0
Merci
Re,

Comme je te l'avais prédit, c'est pareil, j'ai les même erreurs...

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
codefalse 1127 Messages postés mardi 8 janvier 2002Date d'inscription 21 avril 2009 Dernière intervention - 26 juil. 2008 à 21:35
0
Merci
A tout hasard, mysqld est démarré ?

http://www.ReFlectiv.Net
Commenter la réponse de codefalse
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 27 juil. 2008 à 09:25
0
Merci
oui,

mysqlId est démaré !

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
Evangun 1982 Messages postés dimanche 20 février 2005Date d'inscription 24 septembre 2012 Dernière intervention - 27 juil. 2008 à 10:56
0
Merci
Par curiosité, fais voir le code de config.inc.php stp.

Tu n'as jamais modifié la config de mysql pour te connecter avec des named pipes plutôt que par tcp ?
Commenter la réponse de Evangun
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 27 juil. 2008 à 11:09
0
Merci
ok, voici le fichier config.inc.php :

<?php
/*
Merci de renseigner vos coordonnées mysql !
Si vous ne les renseignez pas, le livre d'or ne marchera pas...
*/


$host = 'localhost'; // Entrez l'adresse de l'hote (adresse du server)
$user = 'root'; // Entrez votre identifiant (login)
$pass = ''; // Entrez votre mot de passe, si vous n'en avez pas, ne touchez pas a cette ligne !
$bdd = 'livre_dor'; // Entrez la base dans laquelle vous voulez que les tables dont a besoin le livre d'or pour fonctionner sois créé...


//------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


mysql_connect($host,$user,$pass) or die(mysql_error());
mysql_select_db($bdd) or die(mysql_error());
?>

C'est quoi des named pipes ?

a++







Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
Evangun 1982 Messages postés dimanche 20 février 2005Date d'inscription 24 septembre 2012 Dernière intervention - 27 juil. 2008 à 12:07
0
Merci
C'est pour limiter l'accès au serveur mysql au réseau local. A tout hasard, essaie de remplacer 'localhost' par '.'
à+
Commenter la réponse de Evangun
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 27 juil. 2008 à 12:10
0
Merci
Ok, j'essai, par contre, as tu un tutorial sur l'utilisation des named pipes ?

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 27 juil. 2008 à 12:19
0
Merci
c'est toujours pareil, je crois qu'a un moment j'avais touhé au fichier my.ini mais comme j'avais demandé de l'aide a juki_webmaster avant de venir ici et qu'il m'avait répondu que ça n'avait rien a voir avec my.ini...

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville
nicomilville 3498 Messages postés lundi 16 juillet 2007Date d'inscription 28 février 2014 Dernière intervention - 27 juil. 2008 à 13:02
0
Merci
ok, ba c'est pas grave, merci !

a++

Si la réponse vous convient, pensez : Réponse acceptée !
Commenter la réponse de nicomilville

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.