PROBLEME NETSEND

Messages postés
408
Date d'inscription
lundi 16 décembre 2002
Statut
Membre
Dernière intervention
18 décembre 2012
- - Dernière réponse : XKaliBur
Messages postés
45
Date d'inscription
vendredi 20 février 2004
Statut
Membre
Dernière intervention
13 février 2007
- 25 mai 2005 à 20:22
En fait j'essaye d'envoyer un message par la fonction net send via internet a ordi qui posssede xp. Si je mjet mon ip ca marche et si je met l'ip de quelqun d'autre ca me me met The message alias could not be found on the network remarque l'expediteur ne marche pas merci d'avance !

#include <stdlib.h>
#include <stdio.h>
#include <conio.h>
#include
#include <windows.h>

void sendmsg();

////////////////////////
void main()
{
sendmsg();
cout<<"Message envoyé";
}
////////////////////////

void sendmsg()
{
char command[9] = "net send";
char fromwho[200] = "Yepaaa";
char computer[20] = "80.13.39.70";
char message[200] = "coucou";
char systemCommand[255];
sprintf(systemCommand,"%s %s %s", command, computer, message,fromwho);
system(systemCommand);
}
Afficher la suite 

2 réponses

Messages postés
42
Date d'inscription
dimanche 3 mars 2002
Statut
Membre
Dernière intervention
24 juin 2008
0
Merci
je crois que net send ne marche via internet (en tout cas avec XP). essaye deja sans ton programme avec une commande ms dos. sinon je ne vois pas d'erreur (sinon que ça aurais pu etre judicieux de passer les parametres à la fonction et de lui faire retourner quelque chose pour savoir comment ça s'est passé...)
FloZix :shy)
Commenter la réponse de FloZix
Messages postés
45
Date d'inscription
vendredi 20 février 2004
Statut
Membre
Dernière intervention
13 février 2007
0
Merci
void main()

{

sendmsg();

std::cout<<"Message envoyé";

}
Commenter la réponse de XKaliBur