CDO.Message

Signaler
-
 Utilisateur anonyme -
Voilà comme d'habitude rien ne marche, je peux pas envoyer de mail.



Erreur :

System.Web.HttpException: Could not
access 'CDO.Message' object. --->
System.Reflection.TargetInvocationException: Exception has been thrown
by the target of an invocation. --->
System.Runtime.InteropServices.COMException (0x80040213): Le transport
a échoué dans sa connexion au serveur. --- End of inner exception stack
trace --- at System.RuntimeType.InvokeDispMethod(String name,
BindingFlags invokeAttr, Object target, Object[] args, Boolean[]
byrefModifiers, Int32 culture, String[] namedParameters) at
System.RuntimeType.InvokeMember(String name, BindingFlags invokeAttr,
Binder binder, Object target, Object[] args, ParameterModifier[]
modifiers, CultureInfo culture, String[] namedParameters) at
System.Web.Mail.LateBoundAccessHelper.CallMethod(Object obj, String
methodName, Object[] args) --- End of inner exception stack trace ---
at System.Web.Mail.LateBoundAccessHelper.CallMethod(Object obj, String
methodName, Object[] args) at
System.Web.Mail.CdoSysHelper.Send(MailMessage message) at
System.Web.Mail.SmtpMail.Send(MailMessage message) at
ASP.forum_formulaire_reponse_aspx.Page_Load(Object sender, EventArgs e)
in
c:\inetpub\wwwroot\principal\modules\forum\forum_formulaire_reponse.aspx:line
84



Mon code :

myMail.From = "AdminForum"

myMail.To = drCurseur("US_Mail")

myMail.Subject = "Suivi du sujet : " & drCurseur("FS_Titre")

myMail.Priority = MailPriority.Low

myMail.BodyFormat = MailFormat.Html

myMail.Body = "<html>L'utilisateur
: " & drCurseur("US_NickName") & " a posté une nouvelle réponse
au sujet " & drCurseur("FS_Titre") & "

Vous
pouvez visualiser ce sujet en cliquant sur ce lien
Voir la
réponse</html>"

SmtpMail.SmtpServer = "localhost"

SmtpMail.Send(myMail)



SVP si qulqu'un peu m'aider... Je le remercie


On a rien sans rien

4 réponses

Messages postés
1
Date d'inscription
samedi 7 février 2004
Statut
Membre
Dernière intervention
24 mars 2005

Salut
Essai de construire un server SMTP virtuel sur IIS et tu l'utilise en tant server pour l'objet SMTPMAIL

HardCoder

J'en ai déjà construit un c'est ça le
truc. Mais la c bon g trouvé le probleme, maintenant mes messages que
j'envoie vont dans le dossier queu et ne bouge plus. J'ai essayé en désactivant mes firewall tien à faire

On a rien sans rien
Messages postés
1
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
10 décembre 2008

essaie ceci:
Dim MyMail
Set myMail=CreateObject("CDO.Message")
myMail.Subject="Sujet CDO"
myMail.From= "mail_de_l'expéditeur"
myMail.To="ton_mail"
myMail.TextBody="contenu du message"
myMail.Send
set myMail=nothing

Salut, merci pour ton info, depuis le temps j'ai trouvé 20 milles autre solutions :D

@++

Le savoir ne vaut rien s'il n'est pas partagé