ProcessWindowsStyle.Hidden ne fonctionne pas

Atoxis29
Messages postés
20
Date d'inscription
mercredi 27 juillet 2011
Statut
Membre
Dernière intervention
19 avril 2012
- 18 avril 2012 à 11:38
Atoxis29
Messages postés
20
Date d'inscription
mercredi 27 juillet 2011
Statut
Membre
Dernière intervention
19 avril 2012
- 19 avril 2012 à 12:02
Bonjour à tous,

J'essai de faire démarrer un processus que j'aimerai cahcé à la vue des utilisateur, mais malheureusement malgrès de nombreuse recherche de solution et de tentative, je n'y suis pas arrivé.

Pouvez-vous m'aider ?

voici mon code :

Process clone = new Process();
System.Security.SecureString secret = new System.Security.SecureString();
foreach (char c in pwd) secret.AppendChar(c);
clone.StartInfo.UserName = user;
clone.StartInfo.Password = secret;
clone.StartInfo.WindowStyle = System.Diagnostics.ProcessWindowStyle.Hidden;
clone.StartInfo.FileName = "dsfo.exe";
clone.StartInfo.Arguments = lblAdress.Text + @" 0 0 " + tmp + "ADC.img";
clone.StartInfo.UseShellExecute = false;
clone.StartInfo.CreateNoWindow = true;
clone.Start();


Merci d'avance.

2 réponses

cs_jopop
Messages postés
1540
Date d'inscription
lundi 26 mai 2003
Statut
Membre
Dernière intervention
1 août 2013
12
18 avril 2012 à 15:02
Salut,

j'ai pas de quoi tester là, donc juste une proposition : t'as tenté avec l'attribut RedirectStandardOutput à true ?
0
Atoxis29
Messages postés
20
Date d'inscription
mercredi 27 juillet 2011
Statut
Membre
Dernière intervention
19 avril 2012

19 avril 2012 à 12:02
Non plus ...
Merci quand même mais je me suis aperçu après mure réflexion, qu l'application toute entière méritait des droit admin.

Autre problème, car impossible de désactivé le ClickOnce.
Je vais créer un autre topique à cet occasion.

Merci pour ton aide jopop.
0