SMESERVER & PHPMyAdmin connecter Dreamweaver [Résolu]

Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention - 30 janv. 2008 à 16:03 - Dernière réponse : Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention
- 31 janv. 2008 à 09:36
Bonjour à tous,

Voilà plusieurs jours que je m'arrache les cheveux, en essayant d'accéder à ma base de données. Afin d'économiser quelques euros, je me suis mis dans la tête d'héberger moi-même mes sites Web qui ne génèrent pas un traffic très important.
Pour ce faire, j'ai récupéré une machine suffisamment puissante que j'ai transformé un server Passerelle/Server dédié en installant linux SME-SERVER. Après plusieurs essais tout marche impec (J'arrive à me connecter à l'interface de gestion du server en local et en distant).
J'ai créé un "IBAY" qui apparaît bien lorsque le nom de domaine est tapé.

Ensuite, mes sites étant en PHP avec interaction sur base de données MySQL, j'ai installé PHPMyAdmin dans l'ibay en question. Tout pareil que SME Server, après plusieurs jours de paramètrage à taton, je suis parvenu à me connecter par le biais du navigateur internet, ce en local, mais également en distant.

Voici maintenant le hic, sur la machine qui me sert à développer, je suis resté en Windows parce que j'utilise Dreamweaver. Cette machine utilise une autre connection Internet et n'est donc PAS RELIEE EN RESEAU LOCAL AVEC LE SERVER.
J'ai réussi à rentrer les paramètres de connection (infos distantes et server d'évaluation). Tout fonctionne, j'ai accès à mes fichiers, je peux les modifier, les mettre à jour, les supprimer etc.

Il reste une ultime chose à faire pour répondre à l'ensemble de mes besoins : - la connection MySQL
et là je BLOQUE !!!!!!

Les éléments à remplir sont :
Server Mysql :
Nom d'utilisateur :
Mot de passe :
base de données :

Je pense rentrer les bons éléments, et voici l'erreur qui apparaît lorsque je mets localhost :

MySQL Error#: 1045
Access denied for user 'yann@localhost' (using passowrd:YES)

Et l'erreur lorsque je mets l'ip du server :

MySQL Error#: 2013
Lost connection to MySQL server during query.

Je ne sais pas si je dois changer quelque chose dans les tables MYSQL créées par défaut. Je n'ai vraiment aucune idée de ce que je dois faire. Je suis débutant et je me donne du mal pour essayer de comprendre le fonctionnement.

Please HELP !!!

Si ces informations ne sont pas assez précises, dites le moi, j'avoue ne pas savoir quelles infos sont importantes pour régler ce problème...

Merci à tous !!

Yann
Afficher la suite 

Votre réponse

9 réponses

Meilleure réponse
Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention - 31 janv. 2008 à 09:36
3
Merci
J'ai trouvé,  j'avais juste bettement glissé une faute d'orthograhe....

Merci Sniark 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 96 internautes ce mois-ci

Commenter la réponse de Sniark
Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention - 30 janv. 2008 à 16:15
0
Merci
Essaye ça

Server Mysql : "url" vers la machine avec le daemon mysqld
Nom d'utilisateur : root (de base c'est souvent ca)
Mot de passe : "" (vide surement)
base de données : nomde ta bdd

Les 3 premiers paramètres sont les plus important

--------------------------------------------------------------------------------------------------
         Il vaut mieux poser une question et passer pour bête que le rester toute sa vie
Commenter la réponse de Teclis01
Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention - 30 janv. 2008 à 16:16
0
Merci
Merci beaucoup, mais c'est quoi le "daemon myqld" ????
Commenter la réponse de Sniark
Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention - 30 janv. 2008 à 16:21
0
Merci
daemon = service
mysqld = service mysql

En gros la machine peut hébeger une bdd

--------------------------------------------------------------------------------------------------
         Il vaut mieux poser une question et passer pour bête que le rester toute sa vie
Commenter la réponse de Teclis01
Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention - 30 janv. 2008 à 16:23
0
Merci
ok, alors mon adresse de server est 81.56.13.48 c'est donc ce que j'essais de rentrer, mais j'obtiens toujours la même erreur....

MySQL Error#: 2013
Lost connection to MySQL server during query.
Commenter la réponse de Sniark
Teclis01 1423 Messages postés mardi 14 décembre 2004Date d'inscription 29 décembre 2012 Dernière intervention - 30 janv. 2008 à 16:32
0
Merci
Là suis pas spécialiste des bdd distantes
Je peux pas trop t'aider j'espere juste que qqun qui a resolu le probleme passera

--------------------------------------------------------------------------------------------------
         Il vaut mieux poser une question et passer pour bête que le rester toute sa vie
Commenter la réponse de Teclis01
Sniark 90 Messages postés mercredi 4 juillet 2007Date d'inscription 22 septembre 2009 Dernière intervention - 30 janv. 2008 à 16:33
0
Merci
Merci quand même !!
Commenter la réponse de Sniark
malalam 10918 Messages postés lundi 24 février 2003Date d'inscription 2 mars 2010 Dernière intervention - 31 janv. 2008 à 08:17
0
Merci
hello,

fais voir le bout de code qui se connecte à ton serveur mysql ?
Commenter la réponse de malalam
malalam 10918 Messages postés lundi 24 février 2003Date d'inscription 2 mars 2010 Dernière intervention - 31 janv. 2008 à 08:17
0
Merci
en remplaçant ton mot de passe et ton login au moins, hein...
Commenter la réponse de malalam

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.