Calcul nombre de jours ouvrés entre deux dates

Soyez le premier à donner votre avis sur cette source.

Snippet vu 29 461 fois - Téléchargée 7 fois

Contenu du snippet

PROCEDURE Jours_Ouvrable(Date_Debut,Date_Fin)

x,Nbre_jours sont des entiers

nJours_Ouvrable est un entier = 0

Nbre_jours = DateDifférence(Date_Debut,Date_Fin)
POUR x = 1 A Nbre_jours
  Trace(DateVersJourEnLettre(Date_Debut))
  SI DateVersJourEnLettre(Date_Debut) <> "Samedi" ET DateVersJourEnLettre(Date_Debut) <> "Dimanche" ALORS
    nJours_Ouvrable++ 
  FIN
  Date_Debut..Jour ++ 
FIN

RENVOYER nJours_Ouvrable


Compatibilité : Windev

Disponible dans d'autres langages :

A voir également

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.