Calcul nombre de jours ouvrés entre deux dates

Soyez le premier à donner votre avis sur cette source.

Snippet vu 28 453 fois - Téléchargée 7 fois

Contenu du snippet

//Dans le code du bouton :
// début de la boucle
BOUCLE
             // prend en valeur la date de retour
                    Yannn est un entier=SAI_Retour_prevu
                    
                    DateVersJour(DateDuJour) // Retourne 2
                    //si les deux date sont identique on sort de la procedure
                    SI SAI_Retour_prevu=SAI_Derniere_sortie ALORS
                                               //si la derniere date est un samedi ou dimanche on sort sans rienb faire d'autre
                                                      SI DateVersJour(SAI_Retour_prevu) > 5 ALORS
                                                            //Info ("fin 01")
                                                            SORTIR
                                                      SINON
                                                      //si la derniere date n'est pas un samedi ou dimanche on compte un jour de plus
                                                            SAI_Saisie3=SAI_Saisie3+1
                                                            //Info ("fin 02")
                                                            SORTIR
                                                      FIN
                    
                    SINON
                                                                                       //si la  date est un samedi ou dimanche on change de jour
                                                                                        SI DateVersJour(SAI_Retour_prevu) > 5 ALORS
                                                                                       //compte un jour en moin valide dans le champs
                                                                                       date_moins_un()
                                                                                       SINON
                                                                                       //si la  date n'est pas un samedi ou dimanche on compte un jour de plus                                                                                    
                                                                                        SAI_Saisie3=SAI_Saisie3+1
                                                                                       //compte un jour en moin valide dans le champs
                                                                                       date_moins_un()
                                                                                       FIN
               FIN 
                    
                    FIN

// enfin dans une procedur Local nommée « date_moins_un() »
// Résumé : prend la date dans "SAI_retour_Prevu" en date valide.
PROCEDURE date_moins_un()
dDate  est une Date
dDate = SAI_Retour_prevu
dDate..Jour--
SI DateValide(dDate) ALORS
       SAI_Retour_prevu = dDate
SINON
       SAI_Retour_prevu = DateSys()
FIN

 


Compatibilité : Windev

Disponible dans d'autres langages :

A voir également

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.