Compression & Decompression ZIP

Soyez le premier à donner votre avis sur cette source.

Snippet vu 19 755 fois - Téléchargée 7 fois

Contenu du snippet

// Compression : Création de l'archive
ResCréation = zipCreé("MonArchive", "C:\Temp\Archive.zip")
SI ResCration = 0 ALORS
    // Ajout d'un fichier dans une archive
    ResAjoutFichier = zipAjouteFichier("MonArchive", ...
              "C:\MonRpertoire\MesFichiers\Fichier.pdf", zipDisque)
FIN
// Décompression
// Ouverture d'une archive
ResOuvreArchive = zipOuvre("Archive", "C:\Archives\Archive.zip")
SI ResOuvreArchive = 0 ALORS
   ...
   // Extraction de tous les fichiers de l'archive
   ResExtraitTout = zipExtraitTout("Archive", zipDisque)
   ...
FIN



Compatibilité : Windev

Disponible dans d'autres langages :

A voir également

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.