Blog préfabriqué.

Soyez le premier à donner votre avis sur cette source.

Vue 33 891 fois - Téléchargée 43 303 fois

Description

Comme s'il n'y en avait pas assez, nous avons, avec un ami, créé un préfabriqué de blog.
C'est un projet d'école, avec un sujet libre, et comme nous voulions coder un truc sympa en php et surtout qui puisse, peut être, être un jour utilisé par du monde, nous avons pensé à ce type de projet.
Pourquoi? Parce que c'est à la mode (et oui, il faut la suivre ;) ), et surtout, ca fait appel à plusieurs notions qui nous ont permis de progresser dans la connaissance et la maîtrise du php (nous en faisons depuis 1 mois assez intensivement...).

Description rapide : comme tout blog se respectant, il y a une gestion d'articles (ajout via un panneau d'admin à accès "sécurisé"), ajout de commentaires pour ces articles (le design de l'ajout des commentaires sera refait), et quelques options pour les admins (afficher tel ou tel style, défini par des css, et autoriser ou nom une bannière aléatoire)...

Si vous avez des idées, des commentaires, ou des critiques CONSTRUCTIVES, n'hésitez pas ;)

Pour une démo :
Premier thème (bleu) : http://jypees.free.fr
Second thème (gris) : http://naeikindus.free.fr/blog42/

Codes Sources

A voir également

Ajouter un commentaire Commentaires
Messages postés
7
Date d'inscription
lundi 12 avril 2010
Statut
Membre
Dernière intervention
26 juillet 2010

Bon, quelqu'un vient de me solutionner le souci : la donnée 'files_up' en question n'était pas correctement référencée dans le admin.php ! Je propose donc aux auteurs de ce blog de mettre à jour. J'ai un lien pour vous vers le fichier modifié :
http://blog.thouvest.dyndns.info/fichiers_modifies/admin.rar
Merci à Jérémy A. pour sa solution.
Messages postés
7
Date d'inscription
lundi 12 avril 2010
Statut
Membre
Dernière intervention
26 juillet 2010

Je vais alors devoir faire mon blog en HTML et me dispenser de commentaires avec une base MySQL, sauf avec un script externe...
Pourtant, le script fonctionne sur le site de démonstration puisqu'il y a des articles ! Peut-être un souci avec Windows...
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
41
c'est super drole le commentaire precedent...

la source ne foncitonne pas donc c'est php qui merde ?
en l'occurence, c'est du sql, mais bon...
et c'est plus la creation de la table sql que mysql qui a un probleme, ca vient donc de ce script
Messages postés
7
Date d'inscription
lundi 12 avril 2010
Statut
Membre
Dernière intervention
26 juillet 2010

Je suppose que c'est PHP qui ne fonctionne pas parfaitement, mais quand j'ajoute un article, avec ou sans image, avec ou sans fichier joint, j'obtiens toujours le message d'erreur suivant et l'article n'est pas ajouté :

Field 'files_up' doesn't have a default value

Savez-vous d'où ce problème peut venir ? Merci.
Messages postés
8
Date d'inscription
jeudi 13 octobre 2005
Statut
Membre
Dernière intervention
18 février 2011

Bonjour,
Pour le cas où l'on voudrait donner des leçons de langue avec ton shéma de blog (en l'occurance de l'intergalacte standard!), avec plusieurs degrés d'apprentissage, est-il possible de donner plusieurs "niveaux" d'autorisation à un élève pour qu'il accède aux cours par étapes?

Merci, almux
Afficher les 39 commentaires

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.