[c++] [gdi+] tutorial sans mfc

Soyez le premier à donner votre avis sur cette source.

Vue 20 086 fois - Téléchargée 2 427 fois

Description

Le ZIP contient le SDK ainsi que les 2 exemples Basic & Image.

Project : Microsoft Visual Studio 6 - SP6

N'oubliez pas d'ajouter dans Visual studio les chemins d'accès pour les fichiers .H du SDK & .LIB
Sous Visual : Tools -> Options -> (onglet) Directories
-> Includes Files
-> Library Files

(en haut de la liste pour etre prioritaire sur les autres chemins

Conclusion :


L'intégration sous .NET est quasi similaire, donc rien de bien particulier à ajouter

Codes Sources

A voir également

Ajouter un commentaire

Commentaires

Messages postés
714
Date d'inscription
mardi 22 avril 2003
Statut
Membre
Dernière intervention
19 janvier 2017

Merci :)
tu peux tjs jetter un oeil à la source, elle n'est pas compliquée à comprendre. L'outil de traçage de périmètre avec le remplissage peut etre super util parfois
Messages postés
6
Date d'inscription
mardi 25 février 2003
Statut
Membre
Dernière intervention
21 février 2007

Je suis débutant en C++ et n'ai pas regardé ta source mais une remarque dans ta description (en haut de la liste pour etre prioritaire sur les autres chemins) m'a enlevé une grosse épine du pied car je ne pouvais compiler un projet que je viens de reprendre. Alors tout simplement merci !!!
Messages postés
7
Date d'inscription
mardi 14 novembre 2000
Statut
Membre
Dernière intervention
21 avril 2005

Oui, je l'ai bien ajouté
(Librairy files et include files...)
(d'ailleurs la partie "BASIC" fonctionne bien, cela prouve qu'il doit trouver les fichiers du SDK_GDI... non ?)

Mais j'ai toujours la meme chose quand je chercher à compiler Image.cpp :(

Peut être j'ai fait une bêtise ailleurs ?
Messages postés
714
Date d'inscription
mardi 22 avril 2003
Statut
Membre
Dernière intervention
19 janvier 2017

Pense à rajouter dans Visual le path ou se trouve le SDK GDI+
(Menu Tools->Options->Directories->Include directories)
(Menu Tools->Options->Directories->Library files)
Messages postés
7
Date d'inscription
mardi 14 novembre 2000
Statut
Membre
Dernière intervention
21 avril 2005

La partie "BASIC" se compile bien, mais je n'arrive pas a linker la partie "IMAGE"...

j'ai une tripotée de "unresolved external symbol"

Y'a t il une manip spéciale que j'ai loupé ?

merci

Chris

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.