Éditeur de map pour un laby 3d --> dev c++

Soyez le premier à donner votre avis sur cette source.

Vue 6 664 fois - Téléchargée 601 fois

Description

Il fabrique, ouvre, des maps pour mon laby 3D :
http://www.cppfrance.com/code.aspx?ID=28528

Il y a un beau scrolling avec le souris et les flèches, des boutons avce affichage de texte, enregistrement et chargemnt d'un fichier, pose de textures, affichage de texte, compteur de FPS... ETC.. même pour ceux qui n'ont pas mon labyrinth, il y a des choses intéressante.
Encore une fois, lisez le Lisez-moi, il est là pour ça...

Conclusion :


Il doit y avoir pas mal de bug dans la pose de texture, j'ai pas encore vraiment testé...

Codes Sources

A voir également

Ajouter un commentaire

Commentaires

GhostMaker
Messages postés
4
Date d'inscription
dimanche 23 janvier 2005
Statut
Membre
Dernière intervention
5 mars 2005
-
Meme en changeant la résolution et les couleurs ça marche pas. Je vais essayer de voir au niveau de la source mais je débute dans le C++, donc je vais peut etre pas voir ou est le problème. Enfin, je pense la technique des exit(o); ça reste dans mes cordes ;-)
Arnaud16022
Messages postés
1329
Date d'inscription
vendredi 15 août 2003
Statut
Membre
Dernière intervention
16 juin 2010
2 -
hum, ta résolution me parait louche... essaye d'en remettre une plus conventionnelle le tmps de lancer le prog, genre 1024*798
et évite les couleurs en 8 et 32 bits, 16 c'est le plus stable.
sullyper
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007
-
Bah je sais pas d'oùs ça vient... dsl, T'as essayé de mettre pleine écran et mode fenêtré je suppose. Moi quand j'essaye ça marche...
Enfin, sinon ce que tu peux faire, c'est recompiler l'édit en changeant les configs, en changeant le nombre de couleurs. Mais bon, je vois pas où elle le problème, moi ça marche, peu importe la résolution.
Autre possibilité, il peut te manquer une image...
Dans le dossier images/ tu as 26 images et un icone (qui sert à rien ;-), et un dossier : boutons/ de 33 images. S'il en manque une soit il t'affiche une erreur, te prévient et quitte le programme, soit ça bug complet car y a pas de test, et oui, l'est pas du tout parfait ce programme, mais bon, en théorie les images tu les as...

Sinon rien ne t'empêche de jeter un coup d'oeil à la source quand même ;-)

PS : autre possibilité pour trouver d'où provient l'erreur, tu mets un exit(o); que tu déplaces au fur et à mesure pour voir à partir d'où ça bug. Une fois que tu sais, si c'est pas important, tu rectifie ou tu supprimes, sinon bah t'es dans la merde... ^^

Enfin si tu trouves ce serait cool de me dire où c'est que je puisse ectifier pour que tout le monde en bénéfici...
GhostMaker
Messages postés
4
Date d'inscription
dimanche 23 janvier 2005
Statut
Membre
Dernière intervention
5 mars 2005
-
ça bug après le message de plein écran. Mon pc c'est un XP pro, résolution : 1280 par 960, nbre de couleurs : j'en sais rien^^'. Mais quand même, ça m'énerve, j'adore analyser le code des éditeurs de map^^.
sullyper
Messages postés
79
Date d'inscription
dimanche 1 juin 2003
Statut
Membre
Dernière intervention
11 mai 2007
-
ça bug quand ? avant d'avoir le message qui te demande si tu le veux en pleine écran ou après ?
Je sais pas ce que c'est car moi y a pas de problème mais bon...
C'est quoi les configs de ton PC (résolution ; nbr de couleur ; version de Windows, Linux...)

Mais je suis pas un expert, loin de là, alors pour t'aider... je risque d'avoir du mal...

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.