Dollz [beta 2]

Soyez le premier à donner votre avis sur cette source.

Vue 9 270 fois - Téléchargée 535 fois

Description

Adaptation du mod "DOLLZ" pour les forums PHPBB et INVISION
C'est une petite poupée toute mignonne jointe à votre signiature.

Dans l'idéale programme sera joint à une base de donné, qui contient les parametres de votre Doll, en fonction de ce que vous postez sur le forum vous gagnez des sous (distribuer par les admin), qui vous permetteront de custumizer votre poupée en lui achetant de plus beau vêtement ou des animaux de compagnie (si c'est pas Kawaï).

On pourra indiquer au flash son Identifiant de la sorte
http://site.com/doll.swf?ID=panda
ou simplement indiquer les config de votre poupé ainsi
http://site.com/doll.swf?corps=11EEFF&vest=EEFFEE.....

A venir dans la suite de ce projet:
-différent style d'élement et choix du sexe de sa poupée
-une petite boutique, dépenser ses sous durement gagner

Source / Exemple :


le projet est encore en developpement mais je mettrais à jour au fur et à mesure les avancé. Pour l'instant j'en suis qu'a 2h de programation avec cette petite source qui permet juste de choisir la couleur des différentes pieces qui composent la poupée.

Le principe est tres simple pour chaque élément il y a 2fois la même image.
une colorisé de maniere uniforme avec une variation de transparance et au dessous l'image original.
J'utilise un fonction de Xum (XumtoHex) tres pratique pour convertir en hexadecimal une valeur entre 0 et 255

Conclusion :


Version actuel BETA 2
illustration de Eden
pour en savoir plus sur le developpement de ce projet ou y participer
http://www.bongawonga.com/forum/index.php?act=ST&f=5&t=149&s=4ffbd6ec52cdffad3324d962d6ffff6a

Codes Sources

A voir également

Ajouter un commentaire

Commentaires

pegase31
Messages postés
6161
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
6 -
Tu es certain de gagner réellement du CPU et du poids en passant par la vectorisation systématique des dessins ?
bongawonga
Messages postés
83
Date d'inscription
lundi 12 janvier 2004
Statut
Membre
Dernière intervention
12 septembre 2004
-
non au contraire, au début j'utilisais des PNG
mais flash ne supporte pas plus de 10PNG affichés (pourquoi??? j'en sais rien)
Et il est hors de question de bosser avec des gifs et difficile de demander à ma petite graphiste de se mettre au vectoriel
les PNG vectoriser sont un bon compromie surtout qu'il pese entre 450octet et 5ko contre 12ko pour tous les éléments en PNG

Coté CPU je suis assez tranquille je fais un rafraichissment en fonction du mouvement de la souris et la mise en couleur se fait uniquement sur une sul objet à la fois de 130x130px. J'ai connu plus gourmand comme processus
Puis flash et les pixel ça fait 2
cs_Syb
Messages postés
25
Date d'inscription
mercredi 12 mars 2003
Statut
Membre
Dernière intervention
11 août 2004
-
heu tu es sur pour tes 10 png affiché ? ^0^; j'ai devellopé des programe avec beaucoup plus de 10 png afficher, animé en code et tout, ca marchais tres bien ^^;
bongawonga
Messages postés
83
Date d'inscription
lundi 12 janvier 2004
Statut
Membre
Dernière intervention
12 septembre 2004
-
C'est la seule explication que j'ai pu trouvé.
Je stockais tous les PNG (8bit avec transparence) dans des MovieClip que j'affichais avec un attachMovie, lorsqu'il arrive au 10iem pile poil, il efface le 1er afficher(exactement comme si je créait un MovisClips sur le même level qu'un autre)

J'ai essaye plein de maniere différent de les afficher
sur la racine, dans des movie clip, avec des duplicate movie, séparer par 10level. Puis j'ai remarquer qu'avec le débugger en faisant joué la fonction pas à pas c'est au 11iem que ça plantais, lors j'ai pensé au rafraichissement et essaye de charger de maniere plus lente avec un setInterval intercallé avec des UdapteStage.....T__T rien a faire.
(pourtant le Movieclip contenant le PNG est bien sur la scene, et me renvoie correctement ses proporiété)
Puis sans retouché le code, j'ai vectorisé toutes les images et impect tout fonctionnait

Si tu as une idée sur le probleme, je suis bien curieux d'en connaitre la solution.

En tout cas je reste avec les images vectorisées, je pense que c'est la meilleur solution pour ce projet, même si ça me fait une manipe suplémentaire

Es-ce que dans les programmes que tu as développé, les PNG était posés manuellement sur la scene ou via un action-Script??
cs_Syb
Messages postés
25
Date d'inscription
mercredi 12 mars 2003
Statut
Membre
Dernière intervention
11 août 2004
-
non il était dans la grand majorité déjà sur la scene,

Cependant, je vient de faire un test dans les meme condition, 14pngs encapsuler dans des mc, que jaffiche grace a attachmovie, je n'ai eu aucun probleme a le faire et les 14 ont repondu present.

Quoi qu'il en soit a mon humble avis ce n'est pas du au png, quoi qu'il y ai dans un mc, je vois pas pourquoi l'as ferais la difference dans leur contenu.

Je me souvient avoir eu le meme probleme avec une dupliquation en masse d'un ellement simple (en vecto), ou systematiquement, les premier dupliqué disparaisais sans explication valable, (ca a fait ca du jour au lendemain, sans changement de code)
soit jai fait une manip que jai pas capté
soit cest un bug de flash qui prend ton fla en grippe, peut etre quand transposant les meme code dans un autre fla ca ne ferait pas le meme bug.

Sinon il y a toujours des moyens de detourné cet enervant bug sil est resistant, en fesant un faux premier mc a dupliqué en dehors de la scene visible, c'est lui qui se morflera le bug dans les dents.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.