C++buider: aujourd'hui,table de caractères.

Soyez le premier à donner votre avis sur cette source.

Snippet vu 3 590 fois - Téléchargée 370 fois

Contenu du snippet

Suppression de cette source par son auteur.
Suppression de cette source par son auteur.
Suppression de cette source par son auteur.

A voir également

Ajouter un commentaire Commentaires
cs_Kirua
Messages postés
3006
Date d'inscription
dimanche 14 avril 2002
Statut
Membre
Dernière intervention
31 décembre 2008

10 août 2003 à 14:58
merci pr les précisions, c'est ce que j'avais pu observer aussi, (les résutlats en "interne" sont corrects), mais je ne savais pas que ça dépendanit de la police utilisée. Thx
JimmyLouis
Messages postés
14
Date d'inscription
jeudi 26 décembre 2002
Statut
Membre
Dernière intervention
13 mai 2015

10 août 2003 à 12:10
Salut Kirua!, A mon humble avis, le code ASCII reste ce qu’il est au point de vu programmation, le fait de taper ou programmer une clef avec son numéro donnera toujours le résultat attendu pour l’employeur mais, en ce qui concerne le visuel, là est une autre histoire car suivant le clavier choisi, la fonte, le langage et le système d’exploitation …….
Dans les fontes nouvelles versions on trouve : € au lieu de Ç avec ALT128, cela provient du fait qu’il a fallu ajouter notre symbole monétaire, DONS PAS DE POSSIBILITEES de faire autrement, à moins de rétrograder en système d’exploitation.
Je ne pense pas détenir la science infuse, mais c’est le résultat de ma recherche.
Sur une machine avec uniquement DOS 6.1 le résultat est bon.
Voilà excuse-moi si j’ai été un peu long… @+
Jimmy
cs_Kirua
Messages postés
3006
Date d'inscription
dimanche 14 avril 2002
Statut
Membre
Dernière intervention
31 décembre 2008

9 août 2003 à 19:15
ah non, c le signe euro qui est mal passé, pourtant chez toi ça a marché, quoiqu'il en soit, j'obtiens bien un signe euro.
comment faire pour tjs obtenir le VRAI code ascii? celui déclaré par l'organisme en charge.
JimmyLouis
Messages postés
14
Date d'inscription
jeudi 26 décembre 2002
Statut
Membre
Dernière intervention
13 mai 2015

9 août 2003 à 09:37
Effectif, suivant les fontes employées: chez moi pour le caractère 128 ex : avec : ALT+128 ou ALT+0199 j’obtient bien « Ç » dans la plus part des fontes.
En Arial et d'autres j'ai « € », et certaines rien. Et tout cela sous WindowsXP avec le clavier bien déclaré.
Dans une fenêtre "Vrais DOS" il y a encore d'autres résultats. Dans ton cas si tu as un "?" en 128 c'est bizare, je ne sais pas sous quel os et clavier tu es...@+ ;-)
Jimmy
cs_Kirua
Messages postés
3006
Date d'inscription
dimanche 14 avril 2002
Statut
Membre
Dernière intervention
31 décembre 2008

8 août 2003 à 18:23
ça ne correspond pas au vrai code ASCII.
regarde le résultat pr le caractère 128, et essaye en tapant ALT+128, tu vois? Ç != ?, c étrange.
en mode dos t sensé avoir la vraie correspondance, et là on obtient bien Ç, c facile à écrire comme prog, essaye tu verras, ça tient en qq lignes.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.