Jeu programmé en direct x 8.1

Soyez le premier à donner votre avis sur cette source.

Vue 7 919 fois - Téléchargée 764 fois

Description

voila, un squelette de jeu en 2D. Le jeu nécessite normalement DX8.1, les versions antérieurs, je n'ai pas testé. J'avais commencé ce programme étudiant, pdt les vacances d'été, mais n'ayant plus beaucoup de temps pour le finir, je vous livre les sources. Sinon les dessins sont très moche, c'est moi qui dessine forcément (sous paint qd même atttention :)). Mais bon la partie intéressante c'est le code ;)
PS:J'ai commencé à programmer en DX grâce aux tutoriaux de programmationworld.com, donc je remercie ces auteurs :)

Source / Exemple :


(voir zip)

Codes Sources

A voir également

Ajouter un commentaire

Commentaires

Messages postés
115
Date d'inscription
jeudi 7 février 2002
Statut
Membre
Dernière intervention
21 mai 2005

oki, merci pour le test :o)
donc pas de probs sous xp
Messages postés
4
Date d'inscription
mardi 17 juin 2003
Statut
Membre
Dernière intervention
20 juin 2003

moi g XP et sa marche tres bien
Messages postés
115
Date d'inscription
jeudi 7 février 2002
Statut
Membre
Dernière intervention
21 mai 2005

salut, je n'ai pas xp, mais je vais étudier ton cas, tu pourrais me dire kels fichiers ont été cré lors du lancer du jeu ?(car qd y a des probs, ça cré des fichiers pour debug normalement) cependant un ami ayant xp l'a testé pour moi et il m'a dit ke ça marchait parfaitement. faut ke je me replonge dedans, je l'ai laissé un peu tombé ce projet, bien dommage :(
Messages postés
20
Date d'inscription
dimanche 14 avril 2002
Statut
Membre
Dernière intervention
19 octobre 2003

if( !MoteurGraphique->InitEngine() ) // mettre un if
return FALSE;

ça viens de la, InitEngine retourne FALSE, alors le pourquoi du comment :p je ne sais guère
Messages postés
20
Date d'inscription
dimanche 14 avril 2002
Statut
Membre
Dernière intervention
19 octobre 2003

Alut, utilisateur de Xp, j'ai en effet un pitit prob : le prog se lance puis se stop avant meme d'afficher le moindre petit pixel :p je n'ai donc pas pu voir les moche bitmaps.
Je vais debug pour voir d'ou cela peut venir ^^
Afficher les 13 commentaires

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.