Inscription
27 novembre 2002
Dernière intervention
20 mai 2005
Interventions
42
Signature

Excel 97 VBA ->projet ou bibliothèque introuvable

projet ou bibliothèque introuvable Bonjour, j'ai développé une application avec excel 97 et plein de code VBA (merci VBFrance ;). Sur mon PC tout est OK. Sur les autres PC du réseau de la boite, à chaque fonction VBA (strconv(), date, Space$(255), etc...) il y a un message d'erreur: Projet ou bibliothèque introuvable. Pourtant d... Lire la suite

peut t'on remplacer la fonction ontime par timer

bonjour j'ai réaliser une macro sous outlook et jaimerai qu'il s'execute automatiquement ttes les 2h par exemple. J'ai vu qu'il y avait une fonction en vba application.ontime mais dans le vba de outook il ne reconnait pas la syntaxe. Je voulai donc le remplacer pas la fontion timer mais celui ci ne fais pas ce que je veux, il lanc... Lire la suite

Pb avec propriété ColorIndex sous Excel 97

Bonjour, Voici mon problème : je souhaite changer la couleur d'une cellule excel 97 en fonction de la valeur d'un élément d'une chaine de caractères. Si le caractère vaut "1", je colore la cellule correspondante en rouge, sinon en blanc. Sous Excel 2000/win2000, ça marche, mais pas sous Excel 97/win95 (je développe sous Excel 2000/w... Lire la suite

saver un fichier excel via VBA sans la macro pour gain de place

Valie, j'ai créé un fichier excel pour faire des devis tous fonctionne trs bien , et fais fait ma propre macro en vba mais quand je sauve la feuille sous un autre nom, il me la sauve bien mais avec la macro, du coup cela prends beaucoup de place sur le disk ! comment faire pour sauver mon document excel via VBA mais sans cette macr... Lire la suite

liaison DDE avec une appli non microsoft

Bonjour, J'aimerai réaliser une application qui communique par lien DDE avec une autre appli non microsoft. J'ai un problème quand j'exécute le début de mon code ! nom de service=GOLDMINE rubrique de service=DATA voila mon source : ... sPhone = txtPhone.Text Text1.LinkMode = 0 Text1.LinkTopic = "GOLDMINE|DATA" T... Lire la suite

liaison dde

Bonjour, je cherchais des sources sur les liaison dde mais j'ai pas trouver ce qu'il me fallait, mon ami google m'a bien trouver des pistes mais rien de bien concret, jouer avec des textbox ou des labels. Un lien pas mal http://camernet.ifrance.com/camernet/vb/dde.htm Mais moi je voudrais recuperer les chaines dans une string, je v... Lire la suite

lien dde

bjr y a til quelqu'un qui s'y connait en lien dde? merci d'avance

Un exemple DDE COMPLET didiou !!!

Bonsoir ou bonjour je n'sais pu ! ça fait des heures que j'essaie de faire un truc et là j'suis à bout alors je craque... je post :o) Je cherche à faire un vbs, sans interface sans rien, 10 lignes à tout péter... qui fasse que quand je l'execute ça m'ouvre un pv sous mIRC (logiciel de chat). Communication DDE certes mais j'ai pas é... Lire la suite

Pb d'affichage UserForm avec vba sur Excel

d.rogo :) Bonjour, J'ai développé une macro avec VBA sur Excel 97 qui fonctionne sans problème (sur PC fixe). J'ai besoin d'utiliser cette macro sur un portable équipé d'Office XP Pro 2002. J'affiche une fenêtre avec un code du type : While Condition Load UserForm1 UserForm1.Show UserForm1.Hide Unload UserForm1 ... Lire la suite

Paramètre pour VLOOKUP - Help me

Hello Je vous expose brièvement mon problème. Je suis sous Excel 2000, j'ai la formule suivante : =RECHERCHEV($A6;'\\chemin d'accès...\[prod40.xls]Mercredi'!$A$1:$E$4488;4;FAUX) Ce que je souhaite c'est saisir dans une cellule le numéro de semaine par exemple 39 et modifier la fonction RECHERCHEV comme ceci : =RECHERCHEV($A6;'\... Lire la suite