Erreur de compile sous Eclipse [Résolu]

Signaler
Messages postés
54
Date d'inscription
lundi 31 juillet 2006
Statut
Membre
Dernière intervention
3 avril 2008
-
Messages postés
54
Date d'inscription
lundi 31 juillet 2006
Statut
Membre
Dernière intervention
3 avril 2008
-
Salut à tous,
J'espère que vous pourrez m'aider je suis à court d'inspiration !
J'ai un projet J2EE sous eclipse avec Apache, JBoss, MySQL et utilisant Struts et Hibernate.
Bref, le pb est simple, j'ai des erreurs de compile sous Eclipse du style :
        package org.apache.commons.logging does not exist
                            [javac] import org.apache.commons.logging.Log;
et
        package org.hibernate does not exist
                            [javac] import org.hibernate.HibernateException;

En gros tous les packages d'apache et hibernate sont inconnus !!!
J'ai vérifié JAVA_HOME, ... et mon workspace est tout beau tout neuf.

Quelqu'un aurait une idée ?
Merci d'avance.

4 réponses

Messages postés
54
Date d'inscription
lundi 31 juillet 2006
Statut
Membre
Dernière intervention
3 avril 2008

Bon ben j'ai trouvé !
C'est le fichier built.properties.xml qui était mal configuré !!!
J'espère que ce topic servira à qqun pour ne pas galérer 2h sur un truc aussi bête !
Merci pour ta réponse DARKSIDIOUS !
Messages postés
15814
Date d'inscription
jeudi 8 août 2002
Statut
Modérateur
Dernière intervention
4 mars 2013
107
Configure le buildpath de ton projet sous eclipse en rajoutant les libraries que tu cite (struts, hibernate, etc.)
Messages postés
54
Date d'inscription
lundi 31 juillet 2006
Statut
Membre
Dernière intervention
3 avril 2008

Le problème est bien là ! elles y sont ! j'ai même vérifié dans le classpath
Messages postés
54
Date d'inscription
lundi 31 juillet 2006
Statut
Membre
Dernière intervention
3 avril 2008

Bizarre,
j'ai remarqué une chose !
Toutes les erreurs concernant Hibernate ou Apache sont issues d'un seul et même dossier source alors que les packages sont appelés à d'autres endroits !!!