Probleme de port pour un serveur dédié de CS 1.6

Signaler
Messages postés
29
Date d'inscription
jeudi 24 mars 2005
Statut
Membre
Dernière intervention
29 mai 2009
-
Messages postés
29
Date d'inscription
jeudi 24 mars 2005
Statut
Membre
Dernière intervention
29 mai 2009
-
Salut,

Voilà j'ai un problème de port sur counter strike 1.6.
Je me connecte sur mon serveur en lan et quand des personnes viennent, je leur demande l'ip. Et cette ip c'est mon ip internet (normal jusque là ^^) puis un port qui suit = 63030 ! Quand je redemarre internet, mon ip change et le port aussi :( ! Du coup je ne peut jamais trouver le port tout seul, je dois attendre que quelqu'un vienne, c'est pénible... car mon serveur est un serveur dédié donc peut fréquenté.
J'ai trouvé le message de Jim qui a le même problème que moi, ici : http://www.commentcamarche.net/forum/affich-2446685-probleme-de-port-pour-un-serveur-de-cs#2007-07-01%2020%3A48%3A19
Mais sans réponse :(.
Si quelqu'un a une idée, je suis preneur !!!
J'ai pensé à un truc pour les codeurs qui pourrait me donner des pistes :
Faire un programme (C / C++ ou autre) qui testerait pour tout les ports (de 60000 à 70000 (car jusqu'à maintenant, le port de mon serveur est toujours tombé dans les 60000 et quelques.)) avec mon ip internet si le serveur existe. Si avec 83.128.43.53:64035 il trouve un serveur alors sa affiche le port !

Bon voilà. Je ne sais pas si j'ai été assez compréhensible mais j'espère de l'aide. Posé vos questions si vous comprennez pas ou vos réponses !

Merci,

Damien

2 réponses

Messages postés
571
Date d'inscription
vendredi 30 décembre 2005
Statut
Membre
Dernière intervention
12 juillet 2012
3
Salut,
Ce programme existe déjà il s'appelle netstat.
Lancer le serveur puis aller dans le menu démarrer/Exécuter taper cmd, puis netstat dans la console.
Messages postés
29
Date d'inscription
jeudi 24 mars 2005
Statut
Membre
Dernière intervention
29 mai 2009

Pour le netstat, je connais mais sa ne m'affiche pas mon port :s.
J'ai pensé à Ethereal qui scan bien et pour l'instant, les tests que j'ai fait non rien donné.

Sinon, pour infos, j'ai déjà créé un serveur d'une autre connexion (avec freebox) et sa a marché nickel, avec l'ip et le port indiqué.
Je continue à chercher alors si vous avez d'autres idées  ;) ! Merci

Damien