Appli delphi

Signaler
Messages postés
44
Date d'inscription
lundi 11 juin 2007
Statut
Membre
Dernière intervention
14 mai 2009
-
Messages postés
1284
Date d'inscription
mardi 28 octobre 2003
Statut
Contributeur
Dernière intervention
3 juillet 2015
-
Bonjour,

J'ai récemment crée une appli sous delphi avec base de données. Seulement, j'ai rencontré une erreur en rapport avec la base. J'ai pourtant établie le lien ODBC. 

Voici l'erreur lors de l'éxécution : 'la table n'existe pas' 'titre: nom d'objet incorrect'. 

Par ailleurs, voici la requete :
R1.SQL.Clear;
R1.SQL.ADD('SELECT * FROM titre');
R1.Open;

Merci d'avance.

4 réponses

Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
68
je suppose que ta base ne contient effectivement pas de Table nommée 'Test'...

gaffe au theme où tu poses ta question...

Vous êtes ici :
Thèmes / CodeS-SourceS / Le Bar / Discussions libres /
Messages postés
44
Date d'inscription
lundi 11 juin 2007
Statut
Membre
Dernière intervention
14 mai 2009

Comment résoudre ce problème?
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
13
Salut,

Tu es sûr de sûr d'avoir une table titre dans ta base ???
Messages postés
1284
Date d'inscription
mardi 28 octobre 2003
Statut
Contributeur
Dernière intervention
3 juillet 2015
13
Salut,


As-tu essayé en mettant "titre" en majuscules ? (des fois c'est sensible à ces choses là...)

Simon