Probleme d'ajout d'enregistrement [Résolu]

Messages postés
35
Date d'inscription
mercredi 16 février 2005
Dernière intervention
8 septembre 2009
- - Dernière réponse : TOUF57
Messages postés
35
Date d'inscription
mercredi 16 février 2005
Dernière intervention
8 septembre 2009
- 2 juil. 2007 à 09:49
bonjour,

J'ai un problème lorsque j'ajoute un enregistrement à ma base par un formulaire.
Le message d'erreur "impossible d'ajouter un enregistrement la clé de jointure de la table blabla n'apparait pas dans l'ensemble des enregistrements".

Or ceci marchait correctement, jusqu'à ce que j'insère une nouvelle table.
Quelle est le remède, ou la cause de ce message?

Dans l'impatience de vous lire, je remercie d'avance tous ceux qui pourront m'aider.
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
35
Date d'inscription
mercredi 16 février 2005
Dernière intervention
8 septembre 2009
1
3
Merci
Merci.

Mami17, le souci c'est que le formulaire me sors tous les enregistrements associés à la table père, mais maintenant il ne veux plus accepter de nouvel enregistrement. Je pense que je vais devoir refaire mon formulaire.

J'avais déjà rencontré ce problème auparavant, et je crois qu'en refaisant le formulaire j'avais tout résolu.

Je te remercie.

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 87 internautes nous ont dit merci ce mois-ci

Commenter la réponse de TOUF57
Messages postés
1884
Date d'inscription
samedi 1 avril 2006
Dernière intervention
20 novembre 2007
3
0
Merci
Salut,


Impossible de donner une réponse avec aussi peu d' informations !
Manquant :
>Code d' insertion
>Structure de la table blabla
>Tables auxquelles elle est liée
>Structure de la table ajoutée


Dans l'impatience de te relire...
Commenter la réponse de chaibat05
Messages postés
56
Date d'inscription
dimanche 11 février 2007
Dernière intervention
16 avril 2008
0
Merci
bonjour
je crois que je connais le probleme peut etre tu as ajouté un enregistrement ou le clé etrangers n'existe pas dans la table parent il faut que tu respectais la relation pere-fils c-a-d n'inserer pas les valeurs qui n'existe pas dans la table pére 
ok 
j'espére que cela va résoudre ton probléme 
Commenter la réponse de mami17

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.