Erreur MFC

Résolu
skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007 - 25 juin 2007 à 14:42
skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007 - 29 juin 2007 à 09:16
Bonjour, j'aurais juste une question....
est-ce que le warning :

LINK : warning LNK4098: defaultlib 'MSVCRT' conflicts with use of other libs; use /NODEFAULTLIB:library

peut provoquer des erreurs lors de l'exécution, erreur du type :

First-chance exception at 0x760b21f4 in program.exe: 0xC0000005: Access violation reading location 0x0000000c.
Unhandled exception at 0x760b21f4 in program.exe: 0xC0000005: Access violation reading location 0x0000000c.

cette erreur ce produit sur des trucs de base de MFC, par ex. l'Aide Contextuelle, si je clique sur le bonton d'aide... paf ca plante et ca fait cette erreur.

Merci

5 réponses

skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007
29 juin 2007 à 09:16
Bon j'ai trouvé.. mon appli était bonne c'est la version d'activeSync que j'utilisé dans mon programme qui est devenu obsolète sur Vista et du coup ça se répercutait sur l'interface graphique (même si n'executé aucune fonction de cette librairie)

il falait juste que je télécharge le Windows Mobile 6.0 SDK pour obtenir la version Vista de la librairie ActiveSync afin de compiler correctement mon programme.

Du coup tout marche impeccable maintenant.
3
SAKingdom Messages postés 3212 Date d'inscription lundi 7 novembre 2005 Statut Membre Dernière intervention 16 février 2009 15
25 juin 2007 à 17:13
Ça ne devrait pas. Ce type d'erreur (0xc0000005) survient, dans la plupart des cas, lorsqu'il y a débordement tampon.

C++ (@++)<!--
0
skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007
26 juin 2007 à 08:42
bah ouais....

mais là je vois pas... surtout que sous XP ça marche niquel... là c'est quand je l'execute sous Vista....
je vais reprendre l'interface graphique de Zéro et voir où ça merde
0
skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007
26 juin 2007 à 11:19
apparamment j'ai quand meme un truc qui merde...
voiçi des warning à l'exécution de mon programme...

Warning: no document names in string for template #162.
Warning: no shared menu for document template #162.
Warning: no document names in string for template #129.
Warning: no shared menu for document template #129.
Warning: failed to load menu for CFrameWnd.

c'est surement ca qui foire ma pile....
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
skalimero64 Messages postés 18 Date d'inscription jeudi 21 août 2003 Statut Membre Dernière intervention 14 novembre 2007
26 juin 2007 à 14:00
bon non en fait c'est ailleurs dans les resources... mais où ????
c'est des resource importé de VC6.0 dans VC2005 et apparemment (d'apres ce que j'ai lu sur le web ça peut causer des problèmes)
0