Pb taille police SSPanel

Résolu
Signaler
Messages postés
3
Date d'inscription
lundi 25 septembre 2006
Statut
Membre
Dernière intervention
20 juin 2007
-
Messages postés
3
Date d'inscription
lundi 25 septembre 2006
Statut
Membre
Dernière intervention
20 juin 2007
-
Bonjour,

Je rencontre actuellement le problème suivant avec les contrôles SSPanel (Sheridan 3D Controls - Threed32.ocx) :


En mode design, je positionne la taille de la police sur 10 (police MS Sans Serif) pour mon SSPanel. Pourtant, une fois que mon application est lancée, la taille garde la valeur 8 !!! (8.2 exactement).
Est-ce que quelqu'un aurait une solution à ce problème très bizarre ???
La seule solution que j'ai trouvée pour l'instant est de repositionner la taille de la police par code dans le Form_Activate (ça ne marche pas si je le mets dans le Form_Load...). Malheureusement, j'ai une centaine d'écrans qui contiennent un ou plusieurs SSPanel ....

Merci pour votre aide.

3 réponses

Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
Bonsoir,

Mystère (du moins avec ce que tu te contentes de nous dire...)

Je ne peux que soupçonner l'existence d'un code par lequel tu redimensionne tes contr^oles (mais n'en sais rien, ma foi, puisque tu ne nous montres aucun code).

Tiens !
Montre-nous simplement un code tout simple où, en modifiant la taille de police d'un Label, cette taille ne serait pas prise en compte (si cette taille existe pour cette police, bien évidemment !...)
Messages postés
3
Date d'inscription
lundi 25 septembre 2006
Statut
Membre
Dernière intervention
20 juin 2007

Je précise que j'ai le même problème avec le nom de la police. Par exemple, si je change la police pour mettre du Arial à la place du MS Sans Serif, une fois l'application lancée, la police affichée revient sur MS Sans Serif. Par contre, la propriété "FontBold" est bien conservée.
De plus, ce problème ne concerne pas uniquement les "SSPanel" mais aussi les "Label" !!!
Messages postés
3
Date d'inscription
lundi 25 septembre 2006
Statut
Membre
Dernière intervention
20 juin 2007

Désolé,
J'ai finalement trouvé l'explication au mystère : effectivement un bout de code planqué dans une fonction globale à l'appli et appelée au chargement de chaque écran....
Merci et désolé pour le dérangement !