Problème de droits

Signaler
Messages postés
31
Date d'inscription
mardi 14 novembre 2006
Statut
Membre
Dernière intervention
22 avril 2008
-
Messages postés
2676
Date d'inscription
vendredi 28 juin 2002
Statut
Membre
Dernière intervention
13 janvier 2016
-
Salut à tous!!

J'ai un problème depuis bientôt deux semaines et je n'ai toujours pas trouvé de réponse. J'espère que quelqu'un ici pourra me sauver la vie!! :-)

Je travail un projet pour mon école. Via une GPO, mon programme sera installé automatiquement sur tous les postes du batiment, jusqu'ici aucun problème. Ensuite, je dois donner la possibilité à l'utilisateur du poste d'installer et de lancer un service que j'ai créé. Si l'utilisateur a les droits administrateur, pas de problème, l'installation et le service fonctionne. Le problème survient lorsque l'utilisateur n'est pas admin. Là, l'installation ne se termine pas pour cause d'accès refusé. De même, si j'installe le service depuis un compte admin et que je reviens sur mon compte normal pour le lancer, même problème.

Le seul moyen que j'ai en ce moment en tête, c'est de faire l'installation du service par une autre GPO et de le lancer automatiquement au démarrage. Là, tout fonctionnerait, mais se n'est pas éxactement de cette facon que mon programme devrait fonctionner. Il est vraiment impératif qu'un utilisateur lambda puisse installer et lancer ce service.

Quelqu'un aurait-il une solution pour que mon voeux se réalise ? :-)

Merci d'avance!!

Miccro

1 réponse

Messages postés
2676
Date d'inscription
vendredi 28 juin 2002
Statut
Membre
Dernière intervention
13 janvier 2016
20
salut,

ben, il n'y a pas bcp d'autres solutions que d'ajouter le groupe des utilisateurs dans ceux qui ont le droit  de charger un driver :
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/gp/543.mspx?mfr=true
http://support.microsoft.com/?kbid=317498

ShareVB