Excel nombre de sélection d'un mot dans le menu déroulant d'une cellule

Résolu
Signaler
Messages postés
29
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
14 juin 2007
-
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
-
Bonjour

Dans un classeur je souhaite compter
dans une autre feuille le nombre de sélection d’un mot dans le menu déroulant d’une cellule. <?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>





Ma formule  =NB.SI('DETAIL DES ANOMALIES TN'!$D$29;"*SECURITE*")





Cela fonctionne mai si je supprime le mot dans le menu déroulant tous revient à zéro. Ce que je souhaite, Une addition à chaque celection sans que soit remis à zéro à la sup du mot dans le menu deroulant.

Merci pour votre aide

momo pancho

7 réponses

Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
19
Qu'est-ce que tu entends par "menu déroulant d'une cellule" ?

une liste de choix ? un filtre ? un menu contextuel ?

MPi
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
19
OK, donc ta liste de choix est liée à une liste sur une autre feuille et, en principe, tu as donné un nom à cette liste pour pouvoir créer la liaison... c'est bien ça ?

Est-ce que tu cherches absolument une formule Excel ?
ou un bout de code VBA ou Fonction Utilisateur pourrait suffire ?

MPi
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
19
Maintenant, est-ce que tu peux m'expliquer clairement ce que tu cherches à faire (?)

Si je regarde ton premier message, tu cherches le nombre de fois qu'apparaît le mot "SECURITE" dans la cellule D29 de la feuille DETAIL DES ANOMALIES TN

Est-ce que cette feuille est celle qui contient la liste de base ou est-ce la feuille dans laquelle les choix ont été faits ? j'imagine que c'est le 2e cas...

Je vais essayer de clarifier ma question pour que la tienne soit plus claire aussi...
Si c'est ce que je pense, tu veux donc savoir le nombre de fois ou un item (ici SECURITE) a été choisi dans la liste...

Si le mot SECURITE (sans accent) est bien dans la cellule, ta formule devrait fonctionner, à la condition que tu mettes toute la plage dans le premier paramètre, du genre
=NB.SI('DETAIL DES ANOMALIES TN'!$D$2:$D$29;"*SECURITE*")

Et si j'ai rien compris, essaie d'être le plus clair possible...

MPi
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
19
C'est normal que ta valeur retourne à 0 puisqu'elle calcule le nombre fois qu'elle apparaît dans la feuille et non le nombre de fois qu'elle est apparue

Ça te prendrait un comteur qui s'incrémente et non une formule NB.SI

Je ne vois pas autre manière qu'en passant par VBA... En fait, je ne vois aucune formule Excel qui permettrait de faire cela...

MPi
Messages postés
29
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
14 juin 2007

Bonjour 

une liste de choix

merci
Messages postés
29
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
14 juin 2007

Pour ta premiere analyse c'est bien ça !

ce que je cherche est une solution pour que cela fonctionne. Peut importe que ce soit un code VBA ou autre

Merci
Messages postés
29
Date d'inscription
jeudi 24 mai 2007
Statut
Membre
Dernière intervention
14 juin 2007

Salut
 
Dans un classeur j'ai un feuille DETAIL DES ANOMALIES TN ou je rentre les données d'un liste de choix  liée à une liste sur une autre feuille.
Dans une autre feuille du même classeur je veux compter le nombre de fois qu'apparaît le mot "SECURITE" dans la cellule D29 de la feuille DETAIL DES ANOMALIES TN.
EXEMPLE : si je sélectionne sécurité dans la liste de choix 1 s'affiche dans RECAP-ROULEUR
PROBLEME : si je supprime le mot SECURITE dans la liste de choix RECAP-ROULEUR est mis à zéro
QUESTION : comment faire pour savoir le nombre de fois ou un item (ici SECURITE) a été choisi dans la liste et ce pour chaque cellule.

EXEMPLE :
DETAIL DES ANOMALIES TN                           RECAP-ROULEUR
  SECURITE                                                                         1
<?xml:namespace prefix = v /??><v:shapetype id="_x0000_t75" stroked="f" filled="f" path="m@4@5l@4@11@9@11@9@5xe" coordsize="21600,21600" u1:spt="75" u1:preferrelative="t"><v:stroke join=""></v:stroke><v:formulas><v:f eqn="if lineDrawn pixelLineWidth 0"></v:f><v:f eqn="sum @0 1 0"></v:f><v:f eqn="sum 0 0 @1"></v:f><v:f eqn="prod @2 1 2"></v:f><v:f eqn="prod @3 21600 pixelWidth"></v:f><v:f eqn="prod @3 21600 pixelHeight"></v:f><v:f eqn="sum @0 0 1"></v:f><v:f eqn="prod @6 1 2"></v:f><v:f eqn="prod @7 21600 pixelWidth"></v:f><v:f eqn="sum @8 21600 0"></v:f><v:f eqn="prod @7 21600 pixelHeight"></v:f><v:f eqn="sum @10 21600 0"></v:f></v:formulas><v:path gradientshapeok="t" u1:extrusionok="f" u1:connecttype="rect"></v:path></v:shapetype><v:shape id="_x0000_i1025"><v:imagedata src="file:///C:\DOCUME~1\maurice\LOCALS~1\Temp\msohtml1\01\clip_image001.wmz" u1:title=""></v:imagedata></v:shape>                                                                                             3
<v:shape id="_x0000_i1026"><v:imagedata src="file:///C:\DOCUME~1\maurice\LOCALS~1\Temp\msohtml1\01\clip_image003.wmz" u1:title=""></v:imagedata></v:shape>  SECURITE                                                                         7

Tu analyse très bien,  ma formule fonctionne mais n'enregistre pas le nombre de fois ou un item (ici SECURITE) a été choisi dans la liste.
  Je peux si tu me le permet t' envoyer par mail le classeur en question !<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>