Php Mysql stocké

Résolu
Signaler
Messages postés
44
Date d'inscription
dimanche 21 novembre 2004
Statut
Membre
Dernière intervention
9 juin 2007
-
Messages postés
44
Date d'inscription
dimanche 21 novembre 2004
Statut
Membre
Dernière intervention
9 juin 2007
-
hello

Voila moi j'ai un petit problème pour charger un code Html à partir d'une base de donnée Mysql



j'ai créé une table papa


j'ai créé un champ id


j'ai créé un champ html

http://img31.picoodle.com/img/img31/8/6/9/f_idm_71430c1.jpg


j'ai mis avec wamp ( dans phpmyadmin )


dans html
bonjour


j'ai été créé une page PHP du nom de CONTENU.PHP


j'ai créé un lien contenu.php et je lui ait assigné un ID = 2


dans la quel j'ai mis ceci

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN""http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

<title>Document sans titre</title>

</head>






 


  mysql_connect("localhost", "xavier", "test");
mysql_select_db("papa");

$ID = intval($_GET['id']);   

$reponse = mysql_query("SELECT html FROM papa WHERE ID='$ID'");

while($donnees = mysql_fetch_array($reponse))
{

echo$donnees['html'];

}
mysql_close();
?>

 

 





</html>

( excusez moi si il y a des balises de code je  ne les ai pas vues )

j'ai doc mis ma page dans  Wamp démarer les serveurs

mais quand je clique sur mon lien rien ne s'affiche

Comment cela se fait il quelqu'un aurait il une idée  ?

Merci d'avance.

1 réponse

Messages postés
44
Date d'inscription
dimanche 21 novembre 2004
Statut
Membre
Dernière intervention
9 juin 2007

enfait il fallait metre

contenu.php?id=2