Symbole disparait???

cs_EFFACEUR Messages postés 38 Date d'inscription vendredi 17 janvier 2003 Statut Membre Dernière intervention 30 décembre 2008 - 7 juin 2007 à 11:44
cs_EFFACEUR Messages postés 38 Date d'inscription vendredi 17 janvier 2003 Statut Membre Dernière intervention 30 décembre 2008 - 7 juin 2007 à 13:48
Bonjour,
J'ai fait des animations en flash, un jeu quitte  ou double ou un autre ou il faut récupérer les éléments qui tombent du ciel.
J'ai remarquer de temps en temps que mes symboles disparaissent expliquation :
Le jeu s appel au paradis : un loup au milieu récupère les objets qui tombe du ciel.
Au démarrage du jeu il y a un bouton jouer quand on clic dessus je fais un gotoandplay(2)
Le loup est bougé avec le X_ tout simplement
Un fois sur 5 mon loup qui est un symbole n'est pas afficher PK?????
Je ne vois pas pourquoi il n'est pas à l'écran.
J'ai le problème avec un autre jeu où c est pas des symboles qui disparaissent mais des boutons.
(quitte ou double les bouton de clic de direction choisi après avoir cliqué sur jouer)
Merci de m aider
salutations

2 réponses

faiblard Messages postés 337 Date d'inscription samedi 3 février 2007 Statut Membre Dernière intervention 4 janvier 2011
7 juin 2007 à 13:11
Si tu fais un gotoandplay la tete de lecture commence a l'image choisi et continue son chemin... donc si y'a pas de stop et que ce n'est pas ta derniere image elle continue... gotoandplay pour un jeu flash c'est bof... aide toi des trace pour commencer a débuger et revient car a mon avis tu as un sérieux probleme de codage...

(Au passage explication et non expliquation (mixage avec équation? :p))

Enjoy
Don't forget accept
0
cs_EFFACEUR Messages postés 38 Date d'inscription vendredi 17 janvier 2003 Statut Membre Dernière intervention 30 décembre 2008
7 juin 2007 à 13:48
Re
désolé pr explication
il y a des stop partout.
Je fait juste des gotoand play quand on change d'image.
image une : légende du jeu + bouton jouer
image 2 : le jeu
image 3 : résultat

J'ai l'impression que c est plus une question de chargement.
La première fois ca n' apparait pas les autres fois oui!!
C'est vrai que je débute en flash mais je ne pense pas avoir fait de bug dans le code.
Vu que ca arrive aux deux jeux  programmés différemments
salutations
0